summaryrefslogtreecommitdiff
path: root/app-text/ronn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/ronn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/ronn')
-rw-r--r--app-text/ronn/Manifest3
-rw-r--r--app-text/ronn/metadata.xml11
-rw-r--r--app-text/ronn/ronn-0.7.3-r3.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/ronn/Manifest b/app-text/ronn/Manifest
new file mode 100644
index 000000000000..9a77d46246c8
--- /dev/null
+++ b/app-text/ronn/Manifest
@@ -0,0 +1,3 @@
+DIST ronn-0.7.3.gem 61440 BLAKE2B 3ff0a1752d7a972b7d8319cac2b1287e7d21207e22b9eb288694172eb9b30b2198e4378eb02df8418585a44d3d2c89b4695675933dc5ef5d9ba63c78e71f4e7c SHA512 885418c88d5a1073f9457ea11e29d82d3bb40ad12506589ccfab83ad447445e41282c9688aba5646082ae5ecc6a047fa9439ffae14561152fc61a136474f611c
+EBUILD ronn-0.7.3-r3.ebuild 1156 BLAKE2B 191a39e5280862710e76e123412cb79f5f352405b41036e80af4a97dd7c0950a9cc3e9c9fe206926b440065cfabb4795c1700e34a3b50afa76ea796b886f7406 SHA512 a4becef0bf262b271e4357bec8378430ae7f2896375339165d4ef2a3b8fb2855bb33c2e33bd6c359cb1941fd9bb0382de2887597b1344656335410e46b4ce187
+MISC metadata.xml 339 BLAKE2B 2a1722a0531a1ccaba0d29a1ace114b95789ba4b0c692e8efcf38605f81de4dd1210671331fcdb5baa6536cf38fbf63f11b85fb13bd6a067be56f22a372fc5b6 SHA512 0be4072cf3514eba60569138ed409362b318616ad4514e319d9b4add120e74fd7655e2fc5c3ab8d7b5d813cfcf8e1054fb98395a1a89d9fb90e447a825ee9439
diff --git a/app-text/ronn/metadata.xml b/app-text/ronn/metadata.xml
new file mode 100644
index 000000000000..dfaa4cf0e494
--- /dev/null
+++ b/app-text/ronn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtomayko/ronn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/ronn/ronn-0.7.3-r3.ebuild b/app-text/ronn/ronn-0.7.3-r3.ebuild
new file mode 100644
index 000000000000..abeb36ab502b
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Converts simple, human readable textfiles to roff for terminal display, and HTML"
+HOMEPAGE="https://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x64-macos ~x64-solaris"
+
+IUSE=""
+
+DEPS="
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+ruby_add_rdepend "${DEPS}"
+
+ruby_add_bdepend "${DEPS}"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}