summaryrefslogtreecommitdiff
path: root/app-text/sword/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/sword/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/sword/files')
-rw-r--r--app-text/sword/files/sword-1.6.2-gcc47.patch35
-rw-r--r--app-text/sword/files/sword-1.7.4-gcc6.patch22
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/sword/files/sword-1.6.2-gcc47.patch b/app-text/sword/files/sword-1.6.2-gcc47.patch
new file mode 100644
index 000000000000..7b55de75b646
--- /dev/null
+++ b/app-text/sword/files/sword-1.6.2-gcc47.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/419505
+
+
+--- a/include/multimapwdef.h
++++ b/include/multimapwdef.h
+@@ -12,21 +12,21 @@ class multimapwithdefault : public std::multimap<Key, T, Compare> {
+ public:
+ typedef std::pair<const Key, T> value_type;
+ T& getWithDefault(const Key& k, const T& defaultValue) {
+- if (find(k) == this->end()) {
+- insert(value_type(k, defaultValue));
++ if (this->find(k) == this->end()) {
++ this->insert(value_type(k, defaultValue));
+ }
+- return (*(find(k))).second;
++ return (*(this->find(k))).second;
+ }
+
+ T& operator[](const Key& k) {
+- if (find(k) == this->end()) {
+- insert(value_type(k, T()));
++ if (this->find(k) == this->end()) {
++ this->insert(value_type(k, T()));
+ }
+- return (*(find(k))).second;
++ return (*(this->find(k))).second;
+ }
+ bool has(const Key& k, const T &val) const {
+- typename std::multimap<Key, T, Compare>::const_iterator start = lower_bound(k);
+- typename std::multimap<Key, T, Compare>::const_iterator end = upper_bound(k);
++ typename std::multimap<Key, T, Compare>::const_iterator start = this->lower_bound(k);
++ typename std::multimap<Key, T, Compare>::const_iterator end = this->upper_bound(k);
+ for (; start!=end; start++) {
+ if (start->second == val)
+ return true;
diff --git a/app-text/sword/files/sword-1.7.4-gcc6.patch b/app-text/sword/files/sword-1.7.4-gcc6.patch
new file mode 100644
index 000000000000..54c79671235e
--- /dev/null
+++ b/app-text/sword/files/sword-1.7.4-gcc6.patch
@@ -0,0 +1,22 @@
+--- sword-1.7.4/configure.ac.old 2016-09-21 18:04:55.029088352 -0400
++++ sword-1.7.4/configure.ac 2016-09-21 18:05:37.870349308 -0400
+@@ -197,7 +197,7 @@
+ fi
+
+
+-AM_CXXFLAGS="$AM_CXXFLAGS -ftemplate-depth-25"
++AM_CXXFLAGS="$AM_CXXFLAGS"
+
+ if test x$enable_warnings = xyes; then
+ AM_CFLAGS="$AM_CFLAGS -Werror"
+--- sword-1.7.4/configure.old 2016-09-21 18:05:05.900008373 -0400
++++ sword-1.7.4/configure 2016-09-21 18:06:03.822112657 -0400
+@@ -16793,7 +16793,7 @@
+ fi
+
+
+-AM_CXXFLAGS="$AM_CXXFLAGS -ftemplate-depth-25"
++AM_CXXFLAGS="$AM_CXXFLAGS"
+
+ if test x$enable_warnings = xyes; then
+ AM_CFLAGS="$AM_CFLAGS -Werror"