summaryrefslogtreecommitdiff
path: root/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild')
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
index 853fc3b700e1..9a0508821fb2 100644
--- a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="2"
+
+inherit eutils
DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
HOMEPAGE="http://fallabs.com/tokyodystopia/"
@@ -15,27 +17,28 @@ IUSE="examples"
DEPEND="dev-db/tokyocabinet"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/fix_rpath.patch"
- "${FILESDIR}/fix_ldconfig.patch"
- "${FILESDIR}/remove_docinst.patch"
-)
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/fix_ldconfig.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
src_configure() {
- econf --libexecdir="${EPREFIX}"/usr/libexec/${PN}
+ econf --libexecdir=/usr/libexec/${PN} || die
}
src_install() {
- HTML_DOCS=( doc/. )
+ emake DESTDIR="${D}" install || die "Install failed"
- default
+ dohtml doc/* || die
if use examples; then
insinto /usr/share/${PF}/example
- doins example/.
+ doins example/* || die "Install failed"
fi
+
}
src_test() {
- emake -j1 check
+ emake -j1 check || die "Tests failed"
}