summaryrefslogtreecommitdiff
path: root/app-text/tree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/tree
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/tree')
-rw-r--r--app-text/tree/Manifest5
-rw-r--r--app-text/tree/files/tree.bashcomp34
-rw-r--r--app-text/tree/metadata.xml15
-rw-r--r--app-text/tree/tree-1.7.0-r1.ebuild42
-rw-r--r--app-text/tree/tree-1.7.0.ebuild41
5 files changed, 137 insertions, 0 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
new file mode 100644
index 000000000000..a919f3dbb453
--- /dev/null
+++ b/app-text/tree/Manifest
@@ -0,0 +1,5 @@
+AUX tree.bashcomp 847 BLAKE2B de05dacd7b54426e89e4afbbb6fba74376212a8f02995ff9babec369244bdb57fcb46989a437a100bf1415f7ecb8b0e142d729bae27f7fef6319de9e4cb06d54 SHA512 8df777721a7974015b5e717d89a4ff8701a2598e227d6cf71077fe498a5bb2a578c96c4667ab80e34b1064e109d38665fb6a4de8f52bb6401445088d5cdca922
+DIST tree-1.7.0.tgz 47082 BLAKE2B 07449f50a44f857733679ae92a54a9dd61fe19b282f9244534393527d5f344835864e2acff3b2c43ed406d65657568b21440044af21fed2c4ab623e88d2e396c SHA512 b234fb1428ba75da72d7e4aeb24bf961e123332342593e441b29a0baa2270d12bb187d889c179d6463c940c8dce9fe9dffeb4ad3f06cf11f057b83234d7b4b4a
+EBUILD tree-1.7.0-r1.ebuild 1073 BLAKE2B 2a915944b3ac6e140591f3dfed56afc3689b64301411f89d9dfb65ce2ea1c24786354e28eb5008f3d01cc9989c598da1f3fce92e32e6043c080db80b97c831ac SHA512 7d895b58b606c9ae4f87efcc111e363afbdba7a1eea3f6feafdc12d3c676e3458c2f120ae955196c0e6b7f46829efc0fe0d7572210ca8e13712652e24b6da0e6
+EBUILD tree-1.7.0.ebuild 1060 BLAKE2B f5eeeafe7a06591a692a8b7f8dafbcea1cf0e10c6f073227bdad412fcd9bb6295a946787d003a50b9e12645a2c135e3601a887851e8777bf0b3a1ee528445692 SHA512 b0ac7ae78f15da79c9fb9a7b622e4715ece42f6767cd1ba4ae4f4f4c46b059956e62cc1442b8eccaa090d5a8096620056a989d7b333af1c1c10e089d9a44449d
+MISC metadata.xml 581 BLAKE2B c8ec671fdf6834012120004fc69b9957364d6c43d6b6dcdd78d1c0a850976d669c4044109c6c08d818a4167be2582cf6b0d20fd634843924a86e031d5d0a8f2c SHA512 ca6717181a7ad2535be2384b4abb986c4daf7d4defc2b4e7d7487fe62b5209c31e81f86843168681debda99dabb6d2c0165b0ca0b154464f5eada572bdc1fe42
diff --git a/app-text/tree/files/tree.bashcomp b/app-text/tree/files/tree.bashcomp
new file mode 100644
index 000000000000..fed493575ea2
--- /dev/null
+++ b/app-text/tree/files/tree.bashcomp
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# bash command-line completion for tree
+# Author: Aaron Walker <ka0ttic@gentoo.org>
+
+_tree() {
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-a -d -l -f -i -q -N -p -u -g -s -D -F -r -t -x -L -A
+ -S -n -C -P -I -H -T -R -o --inodes --device --noreport --nolinks
+ --dirsfirst --charset --help"
+
+ if [[ ${cur} == -* ]] ; then
+ COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
+ return 0
+ fi
+
+ case "${prev}" in
+ -L|-P|-I|-H|-T|--charset|--help)
+ ;;
+ -o)
+ _filedir
+ ;;
+ *)
+ _filedir -d
+ ;;
+ esac
+}
+complete -o filenames -F _tree tree
+
+# vim: set ft=sh tw=80 sw=4 et :
diff --git a/app-text/tree/metadata.xml b/app-text/tree/metadata.xml
new file mode 100644
index 000000000000..c30fee716df8
--- /dev/null
+++ b/app-text/tree/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jstein@gentoo.org</email>
+ <name>Jonas Stein</name>
+ </maintainer>
+ <upstream>
+ <changelog>http://mama.indstate.edu/users/ice/tree/changes.html</changelog>
+ </upstream>
+ <longdescription>Tree is a recursive directory listing command that
+produces a depth indented listing of files, which is colorized ala
+dircolors if the LS_COLORS environment variable is set and output is to tty.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/tree/tree-1.7.0-r1.ebuild b/app-text/tree/tree-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..254228739351
--- /dev/null
+++ b/app-text/tree/tree-1.7.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1"
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:LINUX:__linux__:' tree.c || die
+ mv doc/tree.1.fr doc/tree.fr.1
+ if use !elibc_glibc ; then
+ # 433972, also previously done only for elibc_uclibc
+ sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
+ fi
+ default
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}
diff --git a/app-text/tree/tree-1.7.0.ebuild b/app-text/tree/tree-1.7.0.ebuild
new file mode 100644
index 000000000000..403081c551cc
--- /dev/null
+++ b/app-text/tree/tree-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1"
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:LINUX:__linux__:' tree.c || die
+ mv doc/tree.1.fr doc/tree.fr.1
+ if use !elibc_glibc ; then
+ # 433972, also previously done only for elibc_uclibc
+ sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
+ fi
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ dodoc CHANGES README*
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}