summaryrefslogtreecommitdiff
path: root/app-text/ttf2pk2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
commitfd1824e9b1fd180f410170bf2d02e1f098f53db9 (patch)
tree7d1346df7be9d29e8e8b2d7bd8c36fe016fd917a /app-text/ttf2pk2
parent895ff0a4d41ed3004a73b7869773a26f463c5ded (diff)
gentoo auto-resync : 01:03:2024 - 11:41:16
Diffstat (limited to 'app-text/ttf2pk2')
-rw-r--r--app-text/ttf2pk2/Manifest2
-rw-r--r--app-text/ttf2pk2/ttf2pk2-2.0_p20230311.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/ttf2pk2/Manifest b/app-text/ttf2pk2/Manifest
index 612eac49d178..b8ed6265e024 100644
--- a/app-text/ttf2pk2/Manifest
+++ b/app-text/ttf2pk2/Manifest
@@ -1,3 +1,5 @@
DIST texlive-20210325-source.tar.xz 54837368 BLAKE2B 66bd4bdd43ff53513004b9b9b90ababa0ab5efcf183a27864a3d39cde9cf90721456bda90c49ad6014f4b12d2e6293feaf9a8b152b85a89ffaa96bf5056347df SHA512 afd6eb24efaeac7c58d43ff24162aece919079a9ae02934509f068c7a3828223c33c14d9db11ff7fea3560b08a06f352446ba7f845eefb4a56a87b96f088f213
+DIST texlive-20230311-source.tar.xz 68359984 BLAKE2B 6263e8d3e066db96f071138f2442b1ed7e1f3db7e6d261cdeb9a7e6e636c6e6ed45305c6bda3ab6f9a439c92eabf32a79bf6e371d16b747eebbc05ee47b85035 SHA512 93ac43f3055fee0103a6cfceea18d39ece63984914f3af9ad76da218f2d568852d9b987d1c9647c1497b985e4ffa297ef97dc2d50d3e90f62b03ad685af31d96
EBUILD ttf2pk2-2.0_p20210325.ebuild 1060 BLAKE2B 928342fbd3df6e4cd2cab4b5645cdac6cbe2a88cdef3e007f185d1ab0cb58a96ba618613023e0fd1cc474072021b5425973739eaf992ff2cbcd47b100b340810 SHA512 ee4fe20390bada3304198bf9f079eaa3b0c92fdec0ec643274ea58b8d5b90a6e7dea47621960b5580c7710a7f2b751b00baec34d1e9818bf1350883d98c4b468
+EBUILD ttf2pk2-2.0_p20230311.ebuild 1062 BLAKE2B 96a47c8934434a372f4bc2f771f2a2f6fd7025e0b0079ca65258625c1afe69209140383a3616fd34bac6f3a95b7f3dc7b05ec472302e3ebf6172109d88785882 SHA512 35e42e59bcc4a64c5f8032463ebf20837412a7ee5afac015586d79f5360401be9697279f2421726abe9d085d2edf99b95b73717923d3926f585190457e0f1c82
MISC metadata.xml 246 BLAKE2B b56c934f8eecd3492d6abe15cf5883fdbc1979c37abbc5ad196e345ee17bb865db5eab10ac7de93bbfce94c4e865bf6b86d5f8bc081b5cb1d3d58d1158b81921 SHA512 b61f56c5e078714565ff9e33c81217e788f78bae9cf10d6ca78a82703a8e08119dff3afa68306eced0b7c62db9220d28efa4c9782e943c991e30b25b9ead82f5
diff --git a/app-text/ttf2pk2/ttf2pk2-2.0_p20230311.ebuild b/app-text/ttf2pk2/ttf2pk2-2.0_p20230311.ebuild
new file mode 100644
index 000000000000..c15767ae7644
--- /dev/null
+++ b/app-text/ttf2pk2/ttf2pk2-2.0_p20230311.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
+HOMEPAGE="https://tug.org/texlive/"
+SRC_URI="https://mirrors.ctan.org/systems/texlive/Source/texlive-${PV#*_p}-source.tar.xz"
+S="${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Note about blockers: it is a freetype2 based replacement for ttf2pk and
+# ttf2tfm from freetype1, so block freetype1.
+# It installs some data that collides with
+# dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
+# meanwhile we can start dropping freetype1.
+RDEPEND="
+ >=dev-libs/kpathsea-6.2.1
+ media-libs/freetype:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-system-kpathsea \
+ --with-system-freetype2 \
+ --with-system-zlib
+}