summaryrefslogtreecommitdiff
path: root/app-text/u2ps/u2ps-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/u2ps/u2ps-0.8.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/u2ps/u2ps-0.8.4.ebuild')
-rw-r--r--app-text/u2ps/u2ps-0.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/u2ps/u2ps-0.8.4.ebuild b/app-text/u2ps/u2ps-0.8.4.ebuild
new file mode 100644
index 000000000000..9ba7a301cae0
--- /dev/null
+++ b/app-text/u2ps/u2ps-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="https://sourceforge.net/projects/u2ps.berlios/"
+SRC_URI="mirror://sourceforge/project/${PN}.berlios/${PN}-full-${PV}.tar.gz"
+
+LICENSE="GPL-3 GPL-3-with-font-exception free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/perl-5.6
+ dev-perl/Text-CharWidth
+ app-text/ghostscript-gpl
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-full-${PV}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --with-perl=/usr/bin/perl \
+ --with-gs=/usr/bin/gs \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake
+ emake man
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README DESIGN
+ doman man/u2ps.1
+}