summaryrefslogtreecommitdiff
path: root/app-text/unac/unac-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/unac/unac-1.8.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/unac/unac-1.8.0.ebuild')
-rw-r--r--app-text/unac/unac-1.8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/unac/unac-1.8.0.ebuild b/app-text/unac/unac-1.8.0.ebuild
new file mode 100644
index 000000000000..f5dfcb76a2fb
--- /dev/null
+++ b/app-text/unac/unac-1.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Library and command-line tool for removing accents from characters"
+HOMEPAGE="http://www.nongnu.org/unac/"
+SRC_URI="mirror://debian/pool/main/u/unac/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/libiconv"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-debian-gcc-4.4-bug-556379.patch"
+ epatch "${FILESDIR}/${P}-automake-1.13.1.patch"
+ # otherwise automake will fail
+ touch config.rpath
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README THANKS"
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ einfo "Examples of using unaccent from the command line:"
+ einfo "unaccent utf8 été"
+ einfo "echo -e '\\\\0303\\\\0251t\\\\0303\\\\0251' | unaccent utf8"
+ einfo "unaccent ISO-8859-1 < myfile > myfile.unaccent"
+ einfo
+ einfo "See man unaccent and man unac for more information."
+}