summaryrefslogtreecommitdiff
path: root/app-text/vgrep/vgrep-2.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/vgrep/vgrep-2.5.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/vgrep/vgrep-2.5.1.ebuild')
-rw-r--r--app-text/vgrep/vgrep-2.5.1.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/app-text/vgrep/vgrep-2.5.1.ebuild b/app-text/vgrep/vgrep-2.5.1.ebuild
index 6b7efaf86cf6..bc38ee195178 100644
--- a/app-text/vgrep/vgrep-2.5.1.ebuild
+++ b/app-text/vgrep/vgrep-2.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,25 +11,20 @@ SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
-# Uses golangci-lint
-RESTRICT="test"
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
BDEPEND="dev-go/go-md2man"
DOCS=( README.md )
-# go binary
-QA_PRESTRIPPED="usr/bin/vgrep"
-
src_compile() {
emake build
}
src_install() {
- local prefix="${D}/usr"
- mkdir -p "${prefix}"/bin || die
-
- emake PREFIX="${prefix}" install
+ emake PREFIX="${D}/usr" install
+ einstalldocs
}