summaryrefslogtreecommitdiff
path: root/app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild')
-rw-r--r--app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild b/app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild
new file mode 100644
index 000000000000..dd8c207c466e
--- /dev/null
+++ b/app-text/vilistextum/vilistextum-2.8.0.20200411.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+GITID="06cc8a637efd9097af4f138b1b7c755120ffaa88"
+DESCRIPTION="HTML to ASCII converter programmed to handle incorrect html"
+HOMEPAGE="https://bhaak.net/vilistextum/"
+SRC_URI="https://github.com/bhaak/vilistextum/archive/${GITID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITID}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="unicode"
+
+DEPEND="virtual/libiconv"
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.8.0-prefix.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0.20200411-blockquote.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-towlower.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0.20200411-list-alignment.patch"
+
+ eapply_user
+ eautoreconf
+
+ # wcscasecmp needs extensions, which aren't enabled
+ export ac_cv_func_wcscasecmp=no
+}
+
+get_locale() {
+ locale -a | grep -i "$1\.utf.*8\$"
+}
+
+find_locale() {
+ local l t
+
+ # we basically prefer to find en_US.UTF-8, but it may not always be
+ # available, in which case it is better not to hardcode to use it
+ l=$(get_locale en_US)
+ if [[ -z ${l} ]] ; then
+ for t in "en_GB" "en_.*" ".*" ; do
+ l=$(get_locale ${t})
+ if [[ -n ${l} ]] ; then
+ l=${l%%$'\n'*}
+ break;
+ fi
+ done
+ fi
+ [[ -z ${l} ]] && die "Failed to find a unicode locale"
+ echo "${l}"
+}
+
+src_configure() {
+ # need hardwired locale simply because locale -a | grep -i utf-8 | head -n1
+ # isn't always returning the most sensical (and working) locale
+ econf \
+ $(use_enable unicode multibyte) \
+ $(use_with unicode unicode-locale $(find_locale))
+}
+
+src_test() {
+ if $(locale -a | grep -iq "en_US\.utf.*8"); then
+ emake -j1 check
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.UTF-8 is installed."
+ die "en_US.UTF-8 locale is missing"
+ fi
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ dodoc doc/changes.xhtml doc/htmlmail.xhtml
+}