summaryrefslogtreecommitdiff
path: root/app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
commit56767705335e747c2a8b3f3282e5c1a393352d54 (patch)
treedb29fcdff8c7ce293aa55e7ba797c1242cd601c0 /app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild
parentee2ff072f141c81ba073dc664091d2780d4e74e0 (diff)
gentoo auto-resync : 29:11:2022 - 01:18:33
Diffstat (limited to 'app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild')
-rw-r--r--app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild b/app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..1926b27aecc7
--- /dev/null
+++ b/app-text/wiki2beamer/wiki2beamer-0.10.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool to produce LaTeX Beamer code from wiki-like input"
+
+MY_P=wiki2beamer-v${PV}
+HOMEPAGE="https://wiki2beamer.github.io/"
+SRC_URI="https://github.com/wiki2beamer/wiki2beamer/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-ruby/asciidoctor )"
+
+S="${WORKDIR}/wiki2beamer-${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-doc-examples-makefile.patch
+ "${FILESDIR}"/${P}-doc-man-makefile.patch
+)
+
+src_compile() {
+ use doc && emake -C doc/man/ wiki2beamer.1
+}
+
+src_install() {
+ use examples && dodoc -r doc/examples
+
+ use doc && doman doc/man/${PN}.1
+ dodoc ChangeLog README.md
+
+ python_doscript code/${PN}
+}