summaryrefslogtreecommitdiff
path: root/app-text/xapian-omega
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
commitd8a7472fc6314625f7d16e0427004eb448412908 (patch)
tree0dba2e223a5a5e200a4b84a4a5e3ff690e5059e7 /app-text/xapian-omega
parent8e49340ce0aaf205556648d8fa27dd30e8cf4435 (diff)
gentoo auto-resync : 09:09:2024 - 12:30:03
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest2
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.26.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 09df9591492c..6215da402cbb 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -1,3 +1,5 @@
DIST xapian-omega-1.4.25.tar.xz 578904 BLAKE2B d0bb62741f7c58d1398a4dc8bca3de2b385094fb8126a4e36f424cb09964ac350709bf6dabc38d8d7ebf5f3fcd213d2a444d8e5e5cc52c6353f1c72fc7eebd72 SHA512 2b0d855baaaabbf6da1b86d61f0d3e85d5fb62d1b7d04738a7e15758d0042b9e22f80f0aa273b9a9a21b04dff579c561280e44f2a69a0c0d4f270cb0fbcef169
+DIST xapian-omega-1.4.26.tar.xz 583808 BLAKE2B b5a2779ed5fb4f729e8aa3bd309f09d9867ba8d646121f4f577a5208e1fae605f18c7ecfbcba2fdb8a7ddd54de7f0eb8b8299f0f7d26b272ccdf417fbbf5b2a6 SHA512 576eb82fa972bd0db46c8422695930235ab75677104ec32765421b0e1e813d0c40d3bdace3d88cc66fd28680fbcb75a3adcd808617ae4d7d48e35e0556f908c3
EBUILD xapian-omega-1.4.25.ebuild 1150 BLAKE2B 8611c77e5bcac4900724d336e6bb24c1930d6ff686a819bd05c43cdebc57730876aee8223e066c099bbd24e29fac5f9b4d39658136455ccda73547fedadc0a89 SHA512 cc0039e772c31f9585001b63c850b31be6a7ad842715f5de0377edb9cc017466e6cc5b0ff76c844c9c13b05f9da0f4c62586b34d172667d69b06ef136a26e33e
+EBUILD xapian-omega-1.4.26.ebuild 1156 BLAKE2B e7e50e70595fb909533d815ca95f86b0478625180d54a8f22689ded1e4ce72d00a03ac3d4415898bc109af25f0e811a87ccca8959cbe7294697b25b1f5a31513 SHA512 ab76f9abc419791bb6c537a6128c189f873832795cbb64b822649144d0d1b951defcee16042d2e7b471d1e19b5214005b3bbe27ab185c96ce8afed72901c2cfe
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-text/xapian-omega/xapian-omega-1.4.26.ebuild b/app-text/xapian-omega/xapian-omega-1.4.26.ebuild
new file mode 100644
index 000000000000..1e0983f89c26
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.26.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+HOMEPAGE="https://xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}