summaryrefslogtreecommitdiff
path: root/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xlhtml/xlhtml-0.5.1_p6.ebuild')
-rw-r--r--app-text/xlhtml/xlhtml-0.5.1_p6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
new file mode 100644
index 000000000000..eb983af44ba3
--- /dev/null
+++ b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PV=${PV/_p*/}
+DEB_PR=${PV/*_p/}
+
+DESCRIPTION="Convert MS Excel and Powerpoint files to HTML"
+HOMEPAGE="http://chicago.sourceforge.net/xlhtml/ http://packages.debian.org/etch/xlhtml/"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ ecvs_clean
+ epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PR}.diff
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ docinto cole
+ dodoc cole/{AUTHORS,COPYING,NEWS,ChangeLog,THANKS,TODO}
+
+ docinto ppthtml
+ dodoc ppthtml/{ChangeLog,README,THANKS}
+
+ docinto xlhtml
+ dodoc -r xlhtml/{ChangeLog,README,THANKS,TODO,contrib}
+}