summaryrefslogtreecommitdiff
path: root/app-text/xml2doc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/xml2doc
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/Manifest6
-rw-r--r--app-text/xml2doc/files/xml2doc-pointer_fix.patch20
-rw-r--r--app-text/xml2doc/metadata.xml8
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild59
4 files changed, 93 insertions, 0 deletions
diff --git a/app-text/xml2doc/Manifest b/app-text/xml2doc/Manifest
new file mode 100644
index 000000000000..2cb766a888e9
--- /dev/null
+++ b/app-text/xml2doc/Manifest
@@ -0,0 +1,6 @@
+AUX xml2doc-pointer_fix.patch 627 SHA256 e1274d3084bbe7821e23c1b64658a3df80253fdbcd4dde890a497dd08f813545 SHA512 ebdf69986821fdb1a22e3da4447729433d7f30d08e516b5b28c1f9e4fe6ec98d7a31e925028f940e8a0aaab5c05bd52a1a4d12564fd47a79953b1de606fd2430 WHIRLPOOL c98a9b23803b10f762f91634a2ad5bb5734c5c0d655398493c7c14d817905686d2051a1bd8bae034767f613f8b9c07f9f9349e7ec1afa8701800ee4b1e0ef820
+DIST xml2doc-20030510.tgz 53307 SHA256 dd675754a856f5ca40dfd12e0264ea51228c3d795f853d2310677fd25ea7866e SHA512 9eb2970b7adef1669b9b0aede2b3d2b42ba234c8294f0f8e6e230d8fcc6cf878675b2f0bff87ee36a255ab29376be844d92d382be7aad0ab11972847cfe49dbd WHIRLPOOL 86498838395687896a381dd63897c24cd968f53f16865ef26cde5dcecd63b3a8249bb45ffe65dabd4e18b41a704b22df0d13bcf3862b01ac50dc631a26c7794c
+EBUILD xml2doc-20030510-r1.ebuild 1217 SHA256 e32332c67f1e8be782e43495b37c084f2ea66364a5ad80b99c4ac31aa5ce34c9 SHA512 19ef01d4a2a2ecf59122073e060ee0b13208a113d3839f71969509cfcef3e12597c37963a77daaa3be5223ec40bc9351ddb583ad680e549354dfc9e36535f07e WHIRLPOOL c8438d75e1732ea1b4e98687679606c0a0afddbdc39f13eebe1c84d04af7bf2c9eb961f524bc1d44ab50d58cfdff1107d90e7a8e929736f1a7acdb1ebd5d0e39
+MISC ChangeLog 2570 SHA256 369b1a2d6525fee9fdca311b13fadc5c3a481b8f5276124c6ca73e3d92d4bafe SHA512 0de341ea1668fc344a19aafdf068b843ff209142990aaa6504f1d2a37eda8724b0e1bb5f759bc64b4688ce45d29b38bb61867028e10262ee2101c59d1613d832 WHIRLPOOL 8f5333d0473f1f061ceabb23861832bb671a751c870f5dd2383e23966f51d16d7676a484d5cc54a86625bd1aaa88775b83fb176dbcfe96fdcfcf3ab2ebed3b4b
+MISC ChangeLog-2015 3413 SHA256 1b4e543431786711f6f6e52926fd511e07e6b8c2e38ce8299ab6586d3f268ceb SHA512 d2ad8ff5f8bd6b91333f9f960ea4eeeaf3ddca6fd930b86b510b00aca659447878e3e90a20ea7bfaf9fbea5a1fb6fe0681609d762cd86c64485a20cea1774c89 WHIRLPOOL da57c500c12453cc53e4b93fae0a8e09edf511f983542c452a7312831cbd288adfb5321252c01610c373c16f23c2059179c2dd22cc2b896e0a11fb981fcf88d8
+MISC metadata.xml 244 SHA256 e47a2850f5f6a465f788d214581d433be934c1621dd09d99e8f78772d09e1e3b SHA512 b4abe1dd13476a480e518e284cb832c2b41893049169975ee44edba8661af79b7cd8f8110e03b920fe90cd8e0e1d926bd5a692a24ecb841bd454659de3422ee9 WHIRLPOOL 2c9705675b9abe7fe308ab30a4faf6b31c51eaec76c229bd4fdb9986306824198ad793ddbc868c1792e62a1d40082195e1b532e3b76ef7a71906e0a2263f4bc9
diff --git a/app-text/xml2doc/files/xml2doc-pointer_fix.patch b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
new file mode 100644
index 000000000000..b6adabe3c1a3
--- /dev/null
+++ b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
@@ -0,0 +1,20 @@
+diff -NurdpB xml2doc/src/output_info.c xml2doc-patched/src/output_info.c
+--- xml2doc/src/output_info.c 2003-04-25 05:11:27.000000000 -0500
++++ xml2doc-patched/src/output_info.c 2007-03-14 15:07:59.000000000 -0500
+@@ -9,11 +9,11 @@ void output_info()
+ *subject = xmlGetProp(Doc[n].cur,"subject"),
+ *keywords = xmlGetProp(Doc[n].cur,"keywords"),
+ *trapped = xmlGetProp(Doc[n].cur,"trapped");
+- struct time_t *timet;
+- struct tm *clk;
+-
+- time((time_t *)&timet);
+- clk=localtime((const time_t *)&timet);
++ time_t timet;
++ struct tm *clk;
++
++ time(&timet);
++ clk=localtime(&timet);
+
+ switch(DocS.output)
+ {
diff --git a/app-text/xml2doc/metadata.xml b/app-text/xml2doc/metadata.xml
new file mode 100644
index 000000000000..6109befef74c
--- /dev/null
+++ b/app-text/xml2doc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">xml2doc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
new file mode 100644
index 000000000000..ee66dcf4fb06
--- /dev/null
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
+
+HOMEPAGE="http://xml2doc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
+
+DEPEND=">=dev-libs/libxml2-2.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Fix pointer-related bug detected by a QA notice.
+ epatch "${FILESDIR}/${PN}-pointer_fix.patch"
+
+ # Don't strip symbols from binary (bug #152266)
+ sed -i -e '/^\s*strip/d' \
+ -e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
+ -e '/^\t$(CC) $(CFLAGS) /d' \
+ src/Makefile.in
+}
+
+src_configure() {
+ econf --disable-pdf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+
+ cd "${S}/doc"
+ "${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
+}
+
+src_install() {
+ # xml2doc's make install is unfortunately broken
+
+ # binary
+ dobin src/xml2doc || die
+
+ # documentation
+ dodoc BUGS README TODO || die
+ docinto examples
+ dodoc examples/*.{xml,png} || die
+
+ # manpage
+ doman doc/xml2doc.1 || die
+}