summaryrefslogtreecommitdiff
path: root/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild')
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
index c2ad4628c946..0ff17e1a8107 100644
--- a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
+++ b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit autotools multilib flag-o-matic toolchain-funcs
DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
HOMEPAGE="http://xmlstar.sourceforge.net/"
@@ -21,6 +21,20 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/729600).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ grep -wq _PREFIX/lib m4/xstar-check-libs.m4 || die
+ sed "s,_PREFIX/lib,_PREFIX/$(get_libdir)," -i m4/xstar-check-libs.m4 || die
+ grep -w _PREFIX/lib m4/xstar-check-libs.m4 && die
+
+ eautoreconf
+}
+
src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags libxml-2.0)