summaryrefslogtreecommitdiff
path: root/app-text/zathura-cb/zathura-cb-0.1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 16:04:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 16:04:24 +0000
commit158e7d0067767d034ef3a86a07afbf5bb9bf579f (patch)
treee845f4403370242aa438d03c25ff5813f01af6a4 /app-text/zathura-cb/zathura-cb-0.1.10.ebuild
parent24a48769f03b243065aec42c384c39a2d2306964 (diff)
gentoo auto-resync : 28:02:2023 - 16:04:24
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-0.1.10.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.10.ebuild b/app-text/zathura-cb/zathura-cb-0.1.10.ebuild
new file mode 100644
index 000000000000..fa6f6f40d74b
--- /dev/null
+++ b/app-text/zathura-cb/zathura-cb-0.1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-cb/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
+HOMEPAGE="https://pwmt.org/projects/zathura-cb/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+RDEPEND="app-arch/libarchive:=
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:3"
+
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+BDEPEND="virtual/pkgconfig"