summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
commit40d8bc05c536b6c3fa0bd58c50480dc79c6b9e92 (patch)
tree390b30b3f1aea86e16973b82eb5fa14406fcab7f /app-text
parentfd87b7c771378b2116981e3924bee5805148e118 (diff)
gentoo auto-resync : 22:11:2023 - 23:21:15
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48737 -> 48734 bytes
-rw-r--r--app-text/pdfminer/Manifest2
-rw-r--r--app-text/pdfminer/pdfminer-20221105.ebuild12
3 files changed, 3 insertions, 11 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index a9a00415db31..a2bfc27388ed 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/pdfminer/Manifest b/app-text/pdfminer/Manifest
index cae8374c4b7f..211c6cdd4fe5 100644
--- a/app-text/pdfminer/Manifest
+++ b/app-text/pdfminer/Manifest
@@ -1,5 +1,5 @@
DIST pdfminer-20220506.tar.gz 10853104 BLAKE2B b6008db789973fb69537801b8e928761bd0a949cc72ddf380fd71b6373913f6a689b71bee159e6991e99c196b7e8a1fac5530d2bf9c577e53b8b556bed00b85a SHA512 b81916c70f22f3408cf41a50d35937f950ee6205f59fa03603bc7a78d1b1b037311ebaf5661f6d46b9d4190f2f56189fc28b714463dc5854328c14f97fbc28c4
DIST pdfminer.six-20221105.gh.tar.gz 10857730 BLAKE2B dd9282bfc3c636676f087e6ffc2cfb137f66eee18427f08de488c7bdc13bd27b6cc674d3b75c93d1566668272ee4111e3347664a70152bd4b2f7e4e63664d01b SHA512 72034a75005c91100274f86baa4c8884caad86aacf94ca9d0d5a51d8b3c772aa0bcd766416bed9e26df00bd9a2be585649eaa24321735f532e40a3871e19c6df
EBUILD pdfminer-20220506.ebuild 1123 BLAKE2B d887decf4a6b950d7c70c1d92be1e9a48f2ab6b0b5d841ec27c16691b2958eec6c1a8c71bf6bee285d3a4677d90681d614b5e0e3a0e235887831362f99b60f91 SHA512 e94042adfdf07dca07525e47a31a99ad61da2610b09f533c4229ea79a498a3023e37b9cb8740074f6cd52339ac71d17ad235a04b188791f9919224bcdb9eb964
-EBUILD pdfminer-20221105.ebuild 1209 BLAKE2B 6fac9e69cac3bed7e12b4702ce4acd661a62630142fa1fc8e111aa824adb42dd8a626b283b5b9a99dacaf7a7baa8ad3fd241156b0c45f8554e8b78aa10618897 SHA512 411ec44645ac0c70fe7a115b874d3eceb621020405ee72e805d541b9bfd7a61426e85155ca3175d08f4f2f9fe5f4fd01f1d8a70cadf41b062e7bbb55d08a45fe
+EBUILD pdfminer-20221105.ebuild 1007 BLAKE2B 6cd8185ac5cabef3b85b142b92ebe56fa4c10ea68406e5a8895f7b61e559032e7ec0ff39101890f5bca0658881756c48ed88dfa1203898d202780cf1d9f50a9f SHA512 8295fcd94744d127215054bd8d3d151d0b1478c0c50e1aeb2ed9c1fd9648f18407742a339bca8af720a20fce2ae3f81d0a460c887eb25acaf142365111285fbd
MISC metadata.xml 304 BLAKE2B ff3b83eb539e3b10c265d9a8708bd87ac8c071e19540afea2ff14a41c4643065b2d37e651473e040db8c13f0a80b9d5f2d5346763f458bbfb896aa75e0129b02 SHA512 136520029f2cc0394890d854da1b270537ae36cee617a4ae69923ae8da758705a31b0f023ad973f380efd742a0f45411809b86af67d757c163b5723166a28002
diff --git a/app-text/pdfminer/pdfminer-20221105.ebuild b/app-text/pdfminer/pdfminer-20221105.ebuild
index fd7b84ae99af..fa3139418efc 100644
--- a/app-text/pdfminer/pdfminer-20221105.ebuild
+++ b/app-text/pdfminer/pdfminer-20221105.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
MY_P="${PN}.six-${PV}"
@@ -22,7 +22,7 @@ IUSE="doc examples"
RDEPEND=">=dev-python/charset-normalizer-2.0.0[${PYTHON_USEDEP}]
>=dev-python/cryptography-36.0.0[${PYTHON_USEDEP}]"
-distutils_enable_sphinx docs "dev-python/sphinx-argparse"
+distutils_enable_sphinx docs/source "dev-python/sphinx-argparse"
distutils_enable_tests pytest
python_prepare_all() {
@@ -30,14 +30,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- # Non-standard doc generation
- if use doc; then
- PYTHONPATH="${PYTHONPATH}:${BUILD_DIR}/install" sphinx-build docs/source "${WORKDIR}"/_docs
- HTML_DOCS=( "${WORKDIR}"/_docs/. )
- fi
-}
-
python_install_all() {
use examples && dodoc -r samples
distutils-r1_python_install_all