summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 07:58:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 07:58:50 +0000
commit7819ef4baadbb9171070ce385f7051989fe64e49 (patch)
tree3ceb56418e8596ecbbd740e492938eaa4775bb3a /app-text
parent4921f12d049de1487e17383a32da50a03ea90d65 (diff)
gentoo auto-resync : 23:12:2022 - 07:58:50
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48565 -> 48915 bytes
-rw-r--r--app-text/crengine-ng/Manifest3
-rw-r--r--app-text/crengine-ng/crengine-ng-0.9.2.ebuild58
-rw-r--r--app-text/crengine-ng/metadata.xml28
-rw-r--r--app-text/crqt-ng/Manifest3
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.2.ebuild42
-rw-r--r--app-text/crqt-ng/metadata.xml27
-rw-r--r--app-text/multitail/Manifest2
-rw-r--r--app-text/multitail/multitail-7.0.0.ebuild10
9 files changed, 167 insertions, 6 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index 7dc798400ff1..d0b6c36d69b2 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/crengine-ng/Manifest b/app-text/crengine-ng/Manifest
new file mode 100644
index 000000000000..8919bdfbb7bd
--- /dev/null
+++ b/app-text/crengine-ng/Manifest
@@ -0,0 +1,3 @@
+DIST crengine-ng-0.9.2.tar.bz2 3123671 BLAKE2B 7ecafc398e81fa9771f5728d0fa60fbc6c3fb883a56d09fc4857d92c3d2f997cbbc0d4ac9818bff82d38ffb110463b88663f3298380a15e83df7292dff461cc2 SHA512 09b6f8f9bb747d71258802741d0d8962808279122ed6f2791b2c3813b684bb515206bc8656128e129fc7bcc76bcbb2c485360adb3b60f51377b87f26a1874e05
+EBUILD crengine-ng-0.9.2.ebuild 1634 BLAKE2B 66e9342e3fa43ffc227a022fb82539a755b23fd078989c0851211f0ef798094fd9cc818f67011c9f8010d4efe6457a59eb6e1a4db64c3099e4afef09459ac05f SHA512 c283ac39b48919622238c443af5192440c10ad456d06f049b1f641984e1f1f2597a45c66d52fb8c11a63cf28797e082c6e7a33f9a28462f4b977142883097f5f
+MISC metadata.xml 1225 BLAKE2B f4d77011c511148302e8ca82ca9505a282245a35aafece3a160361734ddd1d8a4c9e2ee62f6200ba32e01138d58a13f1e60ec4ce82625b7b31978b7fb38fc807 SHA512 1d27b4ecd665cb667996c15c1912a9120c3a1a70e44f8394d0f366fa4b5a81682a5f75a43e75570731e4a26f1f8a5570948d09709d1c16604a2ba2d105af9f3c
diff --git a/app-text/crengine-ng/crengine-ng-0.9.2.ebuild b/app-text/crengine-ng/crengine-ng-0.9.2.ebuild
new file mode 100644
index 000000000000..35edaf121645
--- /dev/null
+++ b/app-text/crengine-ng/crengine-ng-0.9.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Cross-platform library designed to implement e-book readers. Supports many e-book formats"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crengine-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+png +jpeg +gif +svg +chm +harfbuzz +fontconfig +libunibreak +fribidi +zstd +libutf8proc lto static-libs"
+
+CDEPEND="sys-libs/zlib
+ png? ( media-libs/libpng:0 )
+ jpeg? ( media-libs/libjpeg-turbo )
+ >=media-libs/freetype-2.10.0
+ harfbuzz? ( media-libs/harfbuzz:= )
+ libunibreak? ( dev-libs/libunibreak:= )
+ fribidi? ( dev-libs/fribidi )
+ zstd? ( app-arch/zstd:= )
+ libutf8proc? ( dev-libs/libutf8proc:= )
+ fontconfig? ( media-libs/fontconfig )"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ ${CDEPEND}"
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DCRE_BUILD_SHARED=ON
+ -DCRE_BUILD_STATIC=$(usex static-libs)
+ -DUSE_COLOR_BACKBUFFER=ON
+ -DWITH_LIBPNG=$(usex png)
+ -DWITH_LIBJPEG=$(usex jpeg)
+ -DWITH_FREETYPE=ON
+ -DWITH_HARFBUZZ=$(usex harfbuzz)
+ -DWITH_LIBUNIBREAK=$(usex libunibreak)
+ -DWITH_FRIBIDI=$(usex fribidi)
+ -DWITH_ZSTD=$(usex zstd)
+ -DWITH_UTF8PROC=$(usex libutf8proc)
+ -DUSE_GIF=$(usex gif)
+ -DUSE_NANOSVG=$(usex svg)
+ -DUSE_CHM=$(usex chm)
+ -DUSE_ANTIWORD=ON
+ -DUSE_FONTCONFIG=$(usex fontconfig)
+ -DUSE_SHASUM=OFF
+ -DBUILD_TOOLS=OFF
+ -DENABLE_UNITTESTING=OFF
+ -DENABLE_LTO=$(usex lto)
+ )
+ cmake_src_configure
+}
diff --git a/app-text/crengine-ng/metadata.xml b/app-text/crengine-ng/metadata.xml
new file mode 100644
index 000000000000..19324ff37cd7
--- /dev/null
+++ b/app-text/crengine-ng/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>valexlin@gmail.com</email>
+ <name>Aleksey Chernov</name>
+ <description>upstream</description>
+ </maintainer>
+ <longdescription lang="en">
+ A fork of coolreader. Supported formats are: fb2 (including fb2.zip), fb3, epub (without DRM),
+ rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
+ </longdescription>
+ <use>
+ <flag name="chm">Support chm format</flag>
+ <flag name="harfbuzz">Use <pkg>media-libs/harfbuzz</pkg> for kerning and ligatures</flag>
+ <flag name="libunibreak">Use <pkg>dev-libs/libunibreak</pkg> for hyphenation</flag>
+ <flag name="fribidi">Support bidirectional text by <pkg>dev-libs/fribidi</pkg></flag>
+ <flag name="libutf8proc">Use <pkg>dev-libs/libutf8proc</pkg> for manipulating unicode strings</flag>
+ <flag name="lto">Use link time optimization</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">coolreader-ng/crengine-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/crqt-ng/Manifest b/app-text/crqt-ng/Manifest
new file mode 100644
index 000000000000..6652d76ff948
--- /dev/null
+++ b/app-text/crqt-ng/Manifest
@@ -0,0 +1,3 @@
+DIST crqt-ng-1.0.2.tar.bz2 419058 BLAKE2B 5d8b6704e6ec226852a0c82cc6c00b386c5b348675f00c4acc9dddbee999f381616083101f183523671ef81bb5036eddb7643b3f31857535d6773a549405ab1c SHA512 f8ebf9d5dec13b69fe7440209cd4da807d25413075b4ad2de885fa73134729be5c23df7d0a73bff061171449e394474ac3779b940120f144d93a7a98eca6cf55
+EBUILD crqt-ng-1.0.2.ebuild 1087 BLAKE2B edaf6f8101555e0227c516b3ae616849c6b19bdb8418641dfbee2b0a2438d9e379f7b85ce67303a388e205bee9c4c78985593e3f3d1386bf34e53c0eee59ebc0 SHA512 e0c99bf02db0e39d2a6d6adbdc8de192766b54fc8a0a126f1bbcd36836f355363cac3e2c43f634eed45e4c042d966a7152a025321472276678418f9a2159a981
+MISC metadata.xml 1166 BLAKE2B b611a0ba6988c389c0a5b18b6e0a35b823529be3b1a5f6dd9f4f10baa82db79c79e9a9be6c709706480b6aa7d5acaecb2283fdd7accea44290bb79d503e52f5b SHA512 e86c87eb1cea3667041359e74f18771da797ed3363935efee7576db38b706c873c6057bccc335d48dc0d6727f5b57c57518c04c6cfb81882124b07a56e541d98
diff --git a/app-text/crqt-ng/crqt-ng-1.0.2.ebuild b/app-text/crqt-ng/crqt-ng-1.0.2.ebuild
new file mode 100644
index 000000000000..ecb531fad955
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND="app-text/crengine-ng[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(-DUSE_QT=QT5)
+ cmake_src_configure
+}
diff --git a/app-text/crqt-ng/metadata.xml b/app-text/crqt-ng/metadata.xml
new file mode 100644
index 000000000000..6aee26085f6e
--- /dev/null
+++ b/app-text/crqt-ng/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>valexlin@gmail.com</email>
+ <name>Aleksey Chernov</name>
+ <description>upstream</description>
+ </maintainer>
+ <longdescription lang="en">
+ A fork of coolreader. Supported formats are: fb2 (including fb2.zip), fb3, epub (without DRM),
+ rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
+ </longdescription>
+ <use>
+ <flag name="chm">Support chm format</flag>
+ <flag name="harfbuzz">Use <pkg>media-libs/harfbuzz</pkg> for kerning and ligatures</flag>
+ <flag name="libunibreak">Use <pkg>dev-libs/libunibreak</pkg> for hyphenation</flag>
+ <flag name="fribidi">Support bidirectional text by <pkg>dev-libs/fribidi</pkg></flag>
+ <flag name="libutf8proc">Use <pkg>dev-libs/libutf8proc</pkg> for manipulating unicode strings</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">coolreader-ng/crqt-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/multitail/Manifest b/app-text/multitail/Manifest
index e2c7d7e1a25f..c6096fdddd31 100644
--- a/app-text/multitail/Manifest
+++ b/app-text/multitail/Manifest
@@ -5,5 +5,5 @@ AUX multitail-7.0.0-gentoo.patch 1029 BLAKE2B 7aa35008a0dc58f82bdde4c2972b7028e6
DIST multitail-6.4.2.tgz 155757 BLAKE2B aba6fea993e0d91071bddcf6d06767773ad6ea6054436dbd8a7163553b1cdfc03040362b87e9b2d31f8fe2165f213c718904f9295d3ab2076707cabf423ae681 SHA512 668c453372ba1e4013aa5191c697bdcaad82c84732841c120a506bee063d2134941e93aed63f96e5aeeb6045829a13aba012f9514dbd9520ab4f1b9b75b42dbd
DIST multitail-7.0.0.tar.gz 152425 BLAKE2B 1afbee9501926b860bd063768e6d20b7e6fe97b7ca8eaeb279639f3ef4f32d3c694650e2471abab067add04fbd1ce7b94dfc2f709baca460e9a36a34cb0746d2 SHA512 325abc2ec3e55f274b8f080c54e878ee301af1df5761def95b5fee0abe65cc999a2db0184e1d7a7378c048b1766e03f9553262d3bba88c8fad87c4952d1d59ae
EBUILD multitail-6.4.2-r1.ebuild 1325 BLAKE2B 266d8fe2b7be9ef97487256010b84d25d046bd16a5790eb920e730d84228b2b7f678a73dd85f3a67a9a38d184f38ef030d92f9153398566f6a4982a99d19284f SHA512 717979028622d84bb660d477aca52ee7f2b1b6ea430a4982e35680830f0a14e7829e7551b96e48784af0f51f9c1f987b1aaa8baf8fd61c211d8f187035b1816f
-EBUILD multitail-7.0.0.ebuild 1542 BLAKE2B 5947c1575da67b12c8bc1bc3a3ea653a3c5823a20d36ba6c57511e2daac2803760c334fd12272b1d815baf3fad1b141bfb264da1d0f3ee3a902e8303dc57c2df SHA512 965e09079358d49af79eacc3b30350bd62599da65b907092a6eb9e5367e73f01c8653d4c1af657d6dd5b2d9d2c15ecefa46bbe0a0e767dad6cb1b70c7400cfb2
+EBUILD multitail-7.0.0.ebuild 1507 BLAKE2B 8da2b0e5ccde03ce9363254435059522f39237988d7ac79d4e82c231784335f13cd7d1b4bf8b6651349d8e361800d5fa226b347e27dc5eb7197c8ed58fc7996c SHA512 92dc2dfa7371058f5b96a3d9955391c25432c1ebea510294f358488ee94b99543d4610a60aa3b3710721c3e09b5ef55b7ecdcc12e8f889ee139e177664948f86
MISC metadata.xml 358 BLAKE2B febc299cf49a8c7bb3a55c83a95fbce0ceb46a9297f91a8d34e6275fb66f7847b08d0facfdcaacc2d88b97af8cf64244712f424a1bfcd11fa866fab7f4d28702 SHA512 834755fd8e98223a18d1487ad8e182bbdd02094b3b52603f7945099dfb0f525a5f08f1d2162b2a5785ce01fd252e4a6b2f4ad9b7ae775e7922ac560a332ea42c
diff --git a/app-text/multitail/multitail-7.0.0.ebuild b/app-text/multitail/multitail-7.0.0.ebuild
index 63fce453c73e..022866ca0977 100644
--- a/app-text/multitail/multitail-7.0.0.ebuild
+++ b/app-text/multitail/multitail-7.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake flag-o-matic optfeature toolchain-funcs
+inherit cmake optfeature
DESCRIPTION="Tail with multiple windows"
HOMEPAGE="http://www.vanheusden.com/multitail/ https://github.com/folkertvanheusden/multitail/"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/folkertvanheusden/${PN}/archive/${PV}.tar.gz -> ${P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~hppa ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="debug examples unicode"
RDEPEND="sys-libs/ncurses:=[unicode(+)?]"
@@ -19,9 +19,9 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-7.0.0-gentoo.patch
- "${FILESDIR}"/${PN}-7.0.0-fix-clang16-build.patch
- "${FILESDIR}"/${PN}-7.0.0-fix-lto-type-mismatch.patch
+ "${FILESDIR}"/${PN}-7.0.0-gentoo.patch
+ "${FILESDIR}"/${PN}-7.0.0-fix-clang16-build.patch
+ "${FILESDIR}"/${PN}-7.0.0-fix-lto-type-mismatch.patch
)
src_prepare() {