summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 02:33:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 02:33:38 +0100
commitb5408a0879b82101f69b6bf3bc29b6e9e4969941 (patch)
tree476433e68266a2cc5100b7d966badf13755311c8 /app-text
parent83b5cde41ddb8fd20de4536dd68eb08da42d013e (diff)
gentoo auto-resync : 18:07:2022 - 02:33:38
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48375 -> 48374 bytes
-rw-r--r--app-text/cherrytree/Manifest2
-rw-r--r--app-text/cherrytree/cherrytree-0.99.48.ebuild91
3 files changed, 93 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index e6772d78e8b1..7518a2e39615 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
index 2365a6f68d40..30578a9275d4 100644
--- a/app-text/cherrytree/Manifest
+++ b/app-text/cherrytree/Manifest
@@ -1,5 +1,7 @@
DIST cherrytree-0.99.37.tar.gz 17983743 BLAKE2B 42e5464f4cba4364dbbdabe5daaf80517a62f3f4b2c1c3efa764e9b10dfae492bf335403d24a7a33d9b7c8cd55a0c55ad359ffca1f639fa7622e00a416defd60 SHA512 2413924d03c65dfad820bc2b1e345b7dd74b69d11a10ee0d333400936eb31368f53f2aee77a3dd708adb3d4b91578c0499766bca4c85537822e9c4b3d41c6800
DIST cherrytree_0.99.47.tar.xz 2457904 BLAKE2B 1072de8ed62757a873a258dc9ab1e9e186128b520e7f02e0a2cd8e7e0173232af7db85e3293efd21b577e51b6f5e55cca0cf35631e34279e32dc07836335b742 SHA512 2611be4c24a188793aa6785d96b33ec91c0957b30616352e1cb2cd12f296e39c29666d37a03016be6c934898bf6deb98af74c2c345d9c70f138f62ac6b10f023
+DIST cherrytree_0.99.48.tar.xz 3474468 BLAKE2B b60cc2ffa4f5bd6e91e2a8b34811ad6977d46bdd02c7c1b2bfcdbf4df6107753a2390bc6a15daae8d5268af017ff52d217ab79ed5b4d5d107ef736257999b865 SHA512 eb4690bbc5865b9a0c7d0cb11341fe5ac17f11d417ad765b29784083a83f18c06a39b5b738838e3d57754de25adf1861ea4a6ad472e01a895e8fce0af0964926
EBUILD cherrytree-0.99.37.ebuild 1938 BLAKE2B 02616be9599b9c31bc85d96f70469be605eff6ad863c5ce7ce68974541d46845ea8ace862635fa2b99ec2fe1335b11d559eae60125236506a6c6c01fd4854c93 SHA512 df1dc2e036a067cb1d0b5d84dc6ea0e4217f68c292c14a94e89161575c6e51bd9a9ac3f473740468af80865a099eb221c467e98ab7d31b132c226b90656bbffe
EBUILD cherrytree-0.99.47-r1.ebuild 2068 BLAKE2B 0443e9b568c60c824fc92b35de0ea863ee272e97487764a2dff4e099ae57846b304baa25effce149cf86ebed2837a7b07479bdf60c7722ff6157d8e21443d4c0 SHA512 3d80785cd39cba9f2c25ec96803b4c9932a97d2282091498642f861ab817193dc68c606659a4b096bd512114fdd348ae62ab4a1766e938f560384f6eafd21663
+EBUILD cherrytree-0.99.48.ebuild 2086 BLAKE2B bfdf9439d30c2e4ca75eba623d87b8967ae48f6a75e7111a3ee607ebd77cfe1558e6ef1aaf38511861cb06a63d88a3ed570724c8f692420a467665201643c1ae SHA512 c5ad0157d2d08e17c1809ec05546807f043dcea30e8584d73c631ec7bbb88915f2319cbdb42a19b3bbc720dbf244c28832e9fe1ef707c565f0e028a44227758a
MISC metadata.xml 251 BLAKE2B 807473dcec4b0ae2f6941f34664628d5842fd525b66aab0dec500b3e9aeb8b5d350edd18e46805bbd71a90aa02e8de98bbce6f5321a3b3bd5b1582a107424cf5 SHA512 e31af6e228e83d7eaff87e8c09c7939ebf20a062ed71ca7ee7fda148e68ea5886025346d30b5429f8358475d98a5f2a09b9a2b32ca280306ac6230a6ae2ff872
diff --git a/app-text/cherrytree/cherrytree-0.99.48.ebuild b/app-text/cherrytree/cherrytree-0.99.48.ebuild
new file mode 100644
index 000000000000..7787d4048a92
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.99.48.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1 xdg
+
+DESCRIPTION="A hierarchical note taking application (C++ version)"
+HOMEPAGE="https://www.giuspen.com/cherrytree https://github.com/giuspen/cherrytree"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/giuspen/cherrytree"
+ S="${WORKDIR}/${P}/future"
+else
+ SRC_URI="https://github.com/giuspen/cherrytree/releases/download/${PV}/${P/-/_}.tar.xz"
+ #SRC_URI="https://github.com/giuspen/cherrytree/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/-/_}
+
+ KEYWORDS="~amd64 ~x86"
+ # S="${WORKDIR}/${PN}-${COMMIT}/future"
+fi
+
+# GPL-3 — future/src/ct (CherryTree)
+# LGPL-2.1 — future/src/7za (7zip)
+# MIT — future/src/fmt (libfmt)
+LICENSE="GPL-3 LGPL-2.1 MIT"
+SLOT="0"
+IUSE="nls test"
+
+# Has deps that aren't available in ::gentoo repo
+RESTRICT="test"
+
+RDEPEND="app-i18n/uchardet
+ app-text/gspell:=
+ >=dev-cpp/glibmm-2.64.2:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0
+ dev-cpp/libxmlpp:2.6
+ dev-cpp/pangomm:1.4
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/libxml2:2
+ dev-libs/fribidi
+ dev-libs/spdlog
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ $(python_gen_any_dep 'dev-python/lxml[${PYTHON_USEDEP}]')"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? (
+ sys-devel/gettext
+ )
+ test? ( dev-util/cpputest )"
+
+python_check_deps() {
+ has_version "dev-python/lxml[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # disable compress man pages
+ sed -i -e \
+ '/install(FILES/s|${MANFILE_FULL_GZ}|${CMAKE_SOURCE_DIR}/data/cherrytree.1|' \
+ CMakeLists.txt || die
+
+ if [[ ${PV} != *9999 ]]; then
+ sed -i \
+ -e "/^set(CT_VERSION/s|\"\(.*\)\"|\"${PV}\"|" \
+ CMakeLists.txt || die
+ fi
+
+ # python_fix_shebang .
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXEC="${PYTHON}"
+ -DUSE_NLS=$(usex nls)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_SHARED_FMT_SPDLOG=ON
+ )
+
+ cmake_src_configure
+}