summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /app-text
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin50107 -> 50108 bytes
-rw-r--r--app-text/libspelling/Manifest2
-rw-r--r--app-text/libspelling/libspelling-0.4.6.ebuild60
-rw-r--r--app-text/xiphos/Manifest2
-rw-r--r--app-text/xiphos/xiphos-4.2.1-r2.ebuild16
5 files changed, 68 insertions, 12 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index 002d15bc8b07..c90f9504d806 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/libspelling/Manifest b/app-text/libspelling/Manifest
index 2dd2452a0437..58093fa14713 100644
--- a/app-text/libspelling/Manifest
+++ b/app-text/libspelling/Manifest
@@ -1,3 +1,5 @@
DIST libspelling-0.4.5.tar.bz2 71413 BLAKE2B 5e6c00d9cd521f560082d76da75fd070a59f3b8dec269db95ffa88f9c216557587e180fcbc7399ea0dbcfe605de024344a4b17af60d4d31b1686f64b5df6fca9 SHA512 ab8fd439855d84c4e681fba0b5030bdcf34d0f4940a3b818aab4d297975acf37e437b141d678a482ebda240d23ecd7875e6c8656be6e1bb3c9c129f2169a8ced
+DIST libspelling-0.4.6.tar.bz2 71184 BLAKE2B ff5a30b7ba43faaf9bd42ed7d85624cf7bf1f5e3c4c242c4c4dbcd79ec92fafc2d0ddc49218d98b7d06b5a7b7aacf6527a0e481c78f8a61bea8b5fa976588de3 SHA512 f5aeda95a116cab8cb84a5ec9567fb9c9fb637b73773a7d0614e39e73de087a13e2cc5b6e1e853c3f2f3dacb38a04f7c44f8f89fe179dfe7689baef704331b65
EBUILD libspelling-0.4.5-r1.ebuild 1185 BLAKE2B 8aa99839dc64339064410b228f25d781d415767d78c1c3bc63c0e3b2521b88badac41807da195a1ee176ca571651064e4823f8498412c182f69262891dd59f46 SHA512 3a9cdac072728dd1970ff9db51b4db7529646c5938ddf73175afa39055839541964e81f45d811d98fd88db5585180c460438a32b283da0cb9f4b7a45fa80329d
+EBUILD libspelling-0.4.6.ebuild 1191 BLAKE2B 8e2a921f2a0f1b3b126ab37c4e8a450c789255ff1f710cb7f1014f96e304af3ebfa4d525fb3befeed473308065f86a9fceb9c0628dedafd4470b470ee42253ad SHA512 5be6390a7c8bfc807497fd70501cac25c8271f840100d06b09be9055a8a6cd85b7da61a44a3400c75baf273d4a476b11964c9f82aab49d13c24bb349673cbca0
MISC metadata.xml 481 BLAKE2B 71fcd160694fe4fe8b7622bbc54b3b67e50190b1f0a9c16e81e008efced3accb2d70a2b8cd18237e24c7318b4f20b628ce1696455c26cd297318abc546f48d34 SHA512 b07a31b0dbb1d0ccd7825476a24ea5b5d9fd86cdd2f860336d798228406b1daa0e10894bd8c0fa5d30b363e870594e3aab48b4b785c8fe7b1b51005dc8ead430
diff --git a/app-text/libspelling/libspelling-0.4.6.ebuild b/app-text/libspelling/libspelling-0.4.6.ebuild
new file mode 100644
index 000000000000..c297188cb6a9
--- /dev/null
+++ b/app-text/libspelling/libspelling-0.4.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson vala
+
+DESCRIPTION="A GNOME library for spellchecking"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libspelling"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="gtk-doc sysprof vala"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.15.5:4
+ >=gui-libs/gtksourceview-5.10.0:5
+ app-text/enchant:2
+ dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+ sysprof? ( dev-util/sysprof-capture:4 )
+ vala? (
+ $(vala_depend)
+ >=gui-libs/gtksourceview-5.6:5[vala]
+ )
+"
+BDEPEND="
+ dev-libs/gobject-introspection
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+src_prepare() {
+ use vala && vala_setup
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denchant=enabled
+ -Dinstall-static=false
+ $(meson_use gtk-doc docs)
+ $(meson_use sysprof)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}
diff --git a/app-text/xiphos/Manifest b/app-text/xiphos/Manifest
index f79b8ea50ab1..2797a1c46834 100644
--- a/app-text/xiphos/Manifest
+++ b/app-text/xiphos/Manifest
@@ -3,5 +3,5 @@ AUX xiphos-4.2.1-glib_version_min_required.patch 223 BLAKE2B f31b00632ce8dcb1df5
AUX xiphos-4.2.1-webkit41.patch 426 BLAKE2B 373d93182db65e5dccb8588658d713961461f49f64170abed279c7158ccf8292fafd44b041ff7cd9ea7bdcb52af34284cba5a7cb0ccd9c5dae6e5d30046d3ea8 SHA512 8a8e8bcb34d257b07eee48249fb46db928fd358765ed3fb35b5f2b5aba6280414fcf25bef3866dbca99bbef90464257409a091e7319f79833c461e23173a2f97
DIST xiphos-4.2.1-disable_webkit_editor.patch.xz 7432 BLAKE2B b1dd9db675a34433f4979247d57936920e178cf83cbcfa0fc2a4b9491855d064ecccdb8805a5615b9c91490c3ff2c24f7d951dad009e83952e5d6aa28c8a0730 SHA512 ae0d9b526143445529fa467bdd1b90015812a5d81396619e64a701962a608413c5875c137970d2b70dbac28085e7f40dc6049d591efaf96df7ddfb2cc64854da
DIST xiphos-4.2.1.tar.xz 21586484 BLAKE2B 7529f770766dfc5bae6cb04bfeb3d3cc0714c4ebbd2282aca549e50b8a9ca4c74cdb8cb69667f1036ee33ee1c5d90e562cff80d520ce72651736e1f5f4274ba1 SHA512 624bd2e931c15e1665724918e756706f048e824dc13c2f1d5a05c32a93697137e75012564a14b7d2d0aa90c6a109c52ead51901e657d35a457ccf5f42204a0fe
-EBUILD xiphos-4.2.1-r2.ebuild 1725 BLAKE2B 3bdd0c1126813b498d073753d0da227bc82085af03daf047698461c36e13863def7d1a0171c092452143a944049f6839aa96d179fb472d5667aef7453e375dde SHA512 8e8abf75f81312867eeff2ee54043924bd9a71f41675e3bd8cf6d6e5458678496edf618311c66e6f5570fce0a9c6b041b90eb3ec6b8d569ea73bd6b897aae711
+EBUILD xiphos-4.2.1-r2.ebuild 1605 BLAKE2B c929b3c29a5775552d6d40e382e8cd17aeb1a26550649963f6b6283cf20ba81403ba0a66a96c9a7f849483dca16d1a83d021148c6cb020a71fa3ed76a3249cb2 SHA512 683d0cadeee5e8b93a3eaeda1a39579865554bb3d349e91bbd59c061376cd82becb2ae250d8fe0d61f65aa1f8011d55306906ee6d562a6bc75f661dc9cc99eeb
MISC metadata.xml 249 BLAKE2B 5e5be0df4c5b4ea63c3a84706d41c581db645af3864178631a0474712b8cb39499deae44655fbb3c2550ecbffcc015a971605a8ecf37d6a8f535628a2208cbba SHA512 141d7ff875c8682681377ca7b753d48ff8311b10fce1f07db9a8ad22bd337dff104834755d7ad45eb1d9394cc5e03a4dd32d784a81d775195766776df9cdad99
diff --git a/app-text/xiphos/xiphos-4.2.1-r2.ebuild b/app-text/xiphos/xiphos-4.2.1-r2.ebuild
index b7ac40476986..0acd0cdd4a59 100644
--- a/app-text/xiphos/xiphos-4.2.1-r2.ebuild
+++ b/app-text/xiphos/xiphos-4.2.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake xdg-utils
+inherit cmake eapi9-ver xdg-utils
DESCRIPTION="A Gtk+-based Bible-study frontend for SWORD"
HOMEPAGE="https://xiphos.org/"
@@ -56,15 +56,9 @@ src_configure() {
pkg_postinst() {
xdg_icon_cache_update
- if [[ -n "${REPLACING_VERSIONS}" ]]; then
- local rver
- for rver in ${REPLACING_VERSIONS}; do
- if ver_test "${rver}" -le "4.2.1"; then
- ewarn "Please note that ${PN} no longer provides an editor due to its dependency on outdated libraries."
- ewarn "Studypad and the personal commentary will no longer work."
- break
- fi
- done
+ if ver_replacing -le "4.2.1"; then
+ ewarn "Please note that ${PN} no longer provides an editor due to its dependency on outdated libraries."
+ ewarn "Studypad and the personal commentary will no longer work."
fi
}