summaryrefslogtreecommitdiff
path: root/app-vim/alternate/alternate-2.18-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/alternate/alternate-2.18-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/alternate/alternate-2.18-r1.ebuild')
-rw-r--r--app-vim/alternate/alternate-2.18-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/alternate/alternate-2.18-r1.ebuild b/app-vim/alternate/alternate-2.18-r1.ebuild
new file mode 100644
index 000000000000..5fce4fba8e50
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=31"
+
+LICENSE="alternate"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+}