summaryrefslogtreecommitdiff
path: root/app-vim/alternate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/alternate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/Manifest7
-rw-r--r--app-vim/alternate/alternate-2.18-r1.ebuild27
-rw-r--r--app-vim/alternate/alternate-2.18-r2.ebuild35
-rw-r--r--app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch18
-rw-r--r--app-vim/alternate/metadata.xml11
5 files changed, 98 insertions, 0 deletions
diff --git a/app-vim/alternate/Manifest b/app-vim/alternate/Manifest
new file mode 100644
index 000000000000..e560ce24b814
--- /dev/null
+++ b/app-vim/alternate/Manifest
@@ -0,0 +1,7 @@
+AUX alternate-2.18-hh-cc-alternation.patch 918 BLAKE2B 0362420f64fdd1607529842d965e4f6bcafa49467e7d6befd9621844f47ff2c1f58e22bd1e1efd5579b6373bd24a0c7974e468cf9edf471a58e964718a25c506 SHA512 b1f524d47785e7482791b56f891e624da2a06739483d0584d080f691eaf89c9a350e708fd1369c41b6f99a263d7395b25572366e0b90b0349230079fbdcea4b9
+DIST alternate-2.18.tar.bz2 7907 BLAKE2B 574369557d3a56b163e7288bc60636649a2c44192c56d1d30464cbc2eb89e672aece59a205d39124e062037b3bc4983f628ae0bed53b7982915c8f9546ec4117 SHA512 397d39a5c5fd186f32f3e0a1651f9b9f739899ffcfdd344e85117c4bb676d8fb8c668410754fefe8934ff1a57537387d49d115dfa17bdca896e423935840ae3f
+DIST alternate-2.18.tar.gz 8652 BLAKE2B f6e50d3e1499fb913f7cfa4ff95df180855c7857a700428be1339916aed4513bf77a8da62b75407a6c129f4da3e3bcd00f5caed53d7a939a2eac96a287a11ffe SHA512 d797b99cbe536285d87c5bb14adfcaa3e18611351c8529d9a0755606e766ecc006f19af5cd9b9535f236220dc525bbc27e1280cbb1e3c71f7444cdefd506cefa
+DIST alternate.txt 8897 BLAKE2B b2c2ad9e39c98c82592034ddb0db79803f39bdf3c8d55307aecc488855a75c7be508b41a6a6cf9d3f3d0f4e938feb65fdd756040d8e51e0244c9dc6b9fbacd86 SHA512 92b24aef5fe1fb459b4cb85ca780ae20126bc79138ac15dec652c15a89b688d40bedc00bdae8fce912c8805b24b8805e45ddbd9e6b1ec10c20e61eed11d37651
+EBUILD alternate-2.18-r1.ebuild 727 BLAKE2B e09fcbd230d6ff7ca1f940556a16483f7fcf9eca457abbfe519fb2c27acbd794b633a96bd2e7ab6f35685832625dd00234374041b1132f122a85854ef48970ef SHA512 1b0932395f1783e4adcad151dc5f12c71938706f15210f26137f6932a30ec17da4f842ddb816e00fb9831bda8c746c3bdc0aa82e091881b7185c1a9c5e6341ac
+EBUILD alternate-2.18-r2.ebuild 1013 BLAKE2B 57659ca6fb819c9bd22975a31f3e51a84062e31d8b9c44944f80cc95d36149c4d476ab6e7ec2da8bd443af6020dc2d83907d7a2c27c487e29f94d35d4fd9c3a5 SHA512 bbf5ef860e9480e8fbc7dd62ffe6999e9c7d1d5a1f1dde913b9f56318415d5884497f77d55b5c1a168174eab00d145b373bd0a1276960cf4597e7f6db26c5c25
+MISC metadata.xml 331 BLAKE2B 2dc5ef5397f37066b5fc7d3a3c5c04185632f538fa6efb5006d0d8aa12d51696464850b2b3a0aea4e7bff8c3e9caf9cbe9e90a312e903d0b5313e29eb5588d3c SHA512 ef4ca068ea9f5409c814ca371c0f68456799bed2bae3019cf2ea3af5c2d13750a059f1d885e2c901cc6549cb7915dcb48abb9d5ce7d67210d89b73d79a2e319d
diff --git a/app-vim/alternate/alternate-2.18-r1.ebuild b/app-vim/alternate/alternate-2.18-r1.ebuild
new file mode 100644
index 000000000000..dd9a4b2a2719
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="https://github.com/vim-scripts/a.vim
+https://www.vim.org/scripts/script.php?script_id=31"
+
+LICENSE="alternate"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+}
diff --git a/app-vim/alternate/alternate-2.18-r2.ebuild b/app-vim/alternate/alternate-2.18-r2.ebuild
new file mode 100644
index 000000000000..5b01204abb9e
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="https://github.com/vim-scripts/a.vim https://www.vim.org/scripts/script.php?script_id=31"
+
+SRC_URI="
+ https://github.com/vim-scripts/a.vim/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://www.vim.org/scripts/download_script.php?src_id=6347 -> ${PN}.txt"
+
+LICENSE="alternate"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+S="${WORKDIR}/a.vim-${PV}"
+
+src_prepare() {
+ default
+ mkdir -p "${S}/doc" || die
+ cp "${DISTDIR}/${PN}.txt" "${S}/doc" || die
+}
diff --git a/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
new file mode 100644
index 000000000000..14b314aa0e0c
--- /dev/null
+++ b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
@@ -0,0 +1,18 @@
+--- a/plugin/a.vim 2005-05-06 22:20:24.000000000 +0100
++++ b/plugin/a.vim 2005-06-20 15:45:45.000000000 +0100
+@@ -57,13 +57,14 @@
+ " Mappings for C and C++
+ call <SID>AddAlternateExtensionMapping('h',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('H',"C,CPP,CXX,CC")
++call <SID>AddAlternateExtensionMapping('hh',"c,cpp,cxx,cc,CC")
+ call <SID>AddAlternateExtensionMapping('hpp',"cpp,c")
+ call <SID>AddAlternateExtensionMapping('HPP',"CPP,C")
+ call <SID>AddAlternateExtensionMapping('c',"h")
+ call <SID>AddAlternateExtensionMapping('C',"H")
+ call <SID>AddAlternateExtensionMapping('cpp',"h,hpp")
+ call <SID>AddAlternateExtensionMapping('CPP',"H,HPP")
+-call <SID>AddAlternateExtensionMapping('cc',"h")
++call <SID>AddAlternateExtensionMapping('cc',"h,hh")
+ call <SID>AddAlternateExtensionMapping('CC',"H,h")
+ call <SID>AddAlternateExtensionMapping('cxx',"h")
+ call <SID>AddAlternateExtensionMapping('CXX',"H")
diff --git a/app-vim/alternate/metadata.xml b/app-vim/alternate/metadata.xml
new file mode 100644
index 000000000000..e9468b3dde77
--- /dev/null
+++ b/app-vim/alternate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/a.vim</remote-id>
+ </upstream>
+</pkgmetadata>