summaryrefslogtreecommitdiff
path: root/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild')
-rw-r--r--app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
new file mode 100644
index 000000000000..f628efe94fd8
--- /dev/null
+++ b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=545"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
+
+src_prepare() {
+ default
+
+ # don't use hi link, bug #101799.
+ sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
+}