summaryrefslogtreecommitdiff
path: root/app-vim/ebnf-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/ebnf-syntax
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/ebnf-syntax')
-rw-r--r--app-vim/ebnf-syntax/Manifest1
-rw-r--r--app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/ebnf-syntax/Manifest b/app-vim/ebnf-syntax/Manifest
index bf0f8d12f2e2..03a432e9f1a4 100644
--- a/app-vim/ebnf-syntax/Manifest
+++ b/app-vim/ebnf-syntax/Manifest
@@ -1,3 +1,4 @@
DIST ebnf-syntax-1.1.tar.bz2 981 BLAKE2B 5ab1916fc909f8b6b4fc139fd34c5c982f2bfac3f4ccfa53f13945787db6b9c6b5531cb805d4a0feea5f3165259cd3a033951fd9074344e62657e067571e5300 SHA512 0fba3be91e998b26a3011bfe18765a3bc3ebde6aa33e96580dc0529d79a067020cfeee614dfa40126a1a968d3ca8e77711eca096095675cf6072061c9be7c083
EBUILD ebnf-syntax-1.1-r2.ebuild 581 BLAKE2B 0b6933ab5ecd0c7935717df68050288240342240ec53483882db356077c19b33f7712739c1042299bb75451302e0928e1f0ec656b76d483bae4f6b02314de275 SHA512 7b2f8c953d6bede17b69d26fbfaaa52a099d32695b36593f4da931a225e195945836e120556552718fd9bce356f04ba9d8f09b47f0717856ccfee07e30071615
+EBUILD ebnf-syntax-1.1-r3.ebuild 579 BLAKE2B ad319147fa4fd1f68c04389b325dfcef3532e97bc69eaf058fa488f66ca365f8f15683a6e4aae3d8205dcc80f14bb5bce406554053ac6b964a266ac2d5980f71 SHA512 a7074684e79a323443bb45407ee2f04ced8fcf1b2c56b8708080651255e9cb5e52239080e2f954e34505bab71311b152ede54c9d6e93bb33a6efefc3f05457ff
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild
new file mode 100644
index 000000000000..c657db10f5a8
--- /dev/null
+++ b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=545"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
+
+src_prepare() {
+ default
+
+ # don't use hi link, bug #101799.
+ sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
+}