summaryrefslogtreecommitdiff
path: root/app-vim/fluxbox-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/fluxbox-syntax
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/fluxbox-syntax')
-rw-r--r--app-vim/fluxbox-syntax/Manifest1
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/Manifest b/app-vim/fluxbox-syntax/Manifest
index ab0f0ab7ab75..5cda4d041ebe 100644
--- a/app-vim/fluxbox-syntax/Manifest
+++ b/app-vim/fluxbox-syntax/Manifest
@@ -1,3 +1,4 @@
DIST fluxbox-syntax-1.5.tar.bz2 1376 BLAKE2B 2006668a89077febb4ec919354359cae1170156950abb553695d6424cb277bca69a5e8ffa93a9e4b09b990e96f9ee34654d34dc15320140dad589808ef9960dc SHA512 0567af6fe0994ea228ac56c3a26485ba5cce7762e3d70d6dced978e56017f6769072c83ae68125de3e03190562a7a10102bef038c02ae148cf70cc0c5951b8df
EBUILD fluxbox-syntax-1.5-r1.ebuild 886 BLAKE2B f59b53cdcae36d9dfe27e6d6ff1b3353ae7a567a95093220127b27717585b0719062bddd485a63cb5586b95b7630c945f119419d15ac4a7d7a1f99a58af7fd79 SHA512 51697c27f4c28d7313d0f6dc72aa4ef0fd549b78c7ad30796dc98798924f2aa4b12aac94fc64f47e016ca703d3fa23b98646680a431ce7ae0ff49439c064dabb
+EBUILD fluxbox-syntax-1.5-r2.ebuild 894 BLAKE2B 80164500b1b6150906445f1b027d48d049ec1c5136f1e02e794b77baac01010453bc8acffeaf2bf6e28e3509cf37ee0d807241343c2eadd8a64952ae7587750b SHA512 c2c0b5361f4a1cb724c5b712638bcceb3888bdbc50c47739352935cb1694d1a3b16bde61dd7624718ce7ae1c346d59ec7a5f7502e73c0474c03e9c2cebf23ccb
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
new file mode 100644
index 000000000000..28e337173b22
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=679"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-vim/genindent"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ mkdir ftdetect || die
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim || die
+}