summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
commit0b832a429ecd6081aa9faa0eb262303b019d87ea (patch)
treec39bb9eaa7bc30cec17f3a3bdef0cf5ed27c6a75 /app-vim/gentoo-syntax
parent80e87db4d9ed551615eb2d0309bf370e79500716 (diff)
gentoo auto-resync : 09:03:2025 - 01:48:35
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-15.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index f66313939dbd..977031ddb4df 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-14.tar.bz2 20988 BLAKE2B 2f11628bec985ef486ad6f04b694df7a2b1e5ef34f5ddb364c7d9dea4a507d9bae4d8de6b00b33358cf651b4fc6816164f22f7760275a1fd0668b89927859cfb SHA512 63914ffb1911d83fa8991a901f9a23ccfc30f0170a6a730cb02919f4adf0ad34c70f4457e006b1c08a004448c6b9e85d97634a8ed8fdf0b4f98ef9fd804eef00
+DIST gentoo-syntax-15.tar.bz2 21018 BLAKE2B 2b0ead6d5701f14f321ad02b1cd3fe426b8e98e4d80e66331387f0543d88a2ac6b5d78a1f8c9125dadf24f3508c34d915fa896dc2fb85a8664984d771b48a29e SHA512 69cdcd58933b4f83da81ecc943e205689591748c283005b2e6cd342e623d8e0643979d913ec6a9464ca2b49431ea2317dfb0e6454143d6757f6ba287286d24f1
EBUILD gentoo-syntax-14.ebuild 1194 BLAKE2B f5178d022e2289ae63adb73bbca9c8b105ed2617a7fd6ca0440d23024b34768cb92cb4955ba93da396de82f4d66d2ca7b2476fe26ccc8fa815b4a69cdc4615a3 SHA512 ead331820bf726b85e9ed7124524b490d3e2edf71bd89b46889116fa7527d1fb70e74d5a5a27e107ca217c3af768e99c33c074992a03230a4bc0c9e9e663c632
+EBUILD gentoo-syntax-15.ebuild 1202 BLAKE2B 496c37cb0a264acbdcc9457c396b92a6e82cbbe39eb3c0b5cbdc3fefa0f497d8dd7640bee0972ea8d9442d57c06a61956d5d72548973f14eac8201f3963a1d96 SHA512 b5329237d00fa4cf32668b2f902b3b31a7719c71493585bd5f6d5a1fe058ca7246ee7c5d91640303c7c9ce042f9885491ce5b968f41c345689dfe25c28b23452
EBUILD gentoo-syntax-9999.ebuild 1076 BLAKE2B 0688da77100e073b40e8b72bd97a6c3cce176f73a36e89489a5536b73a1cd9896222c967c564aa8cac53c5be61be6e7495b4f460f413d899f23a250108d5eb4a SHA512 ee83565cc9c614275d5bbfc5cc33b19cc8af0d170837358e663a63f8de95d86c37f33995e878355dc482d5381ae9dd77fb891c2d484d5e2307d20d85f053a3b8
MISC metadata.xml 646 BLAKE2B d33ab1ce3b852316a114a27c7768310491f51669a44a183c5b2fe639a0d2e65439759de9a83cb019467ef5d206470454bfe1939906d32c1a7fe6ebad0458e14b SHA512 a75bc08e066deac74dc6a8a9927e232be4facc31e0810121480c07e75549de2cbc974eff9f71f2c59fb17f0739bd0cd9cede9a048af4715047a796b6a5afea7d
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-15.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-15.ebuild
new file mode 100644
index 000000000000..2258150d4b4b
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}