summaryrefslogtreecommitdiff
path: root/app-vim/gitgutter/gitgutter-20180316.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /app-vim/gitgutter/gitgutter-20180316.ebuild
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'app-vim/gitgutter/gitgutter-20180316.ebuild')
-rw-r--r--app-vim/gitgutter/gitgutter-20180316.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/gitgutter/gitgutter-20180316.ebuild b/app-vim/gitgutter/gitgutter-20180316.ebuild
new file mode 100644
index 000000000000..002f6583087d
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20180316.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="37bdd03d176c5e182c7e8dbdc79c3f71d2a04898"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm LICENCE README* screenshot.png unplace.vim || die
+ rm -r test || die
+}