summaryrefslogtreecommitdiff
path: root/app-vim/gitgutter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gitgutter
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gitgutter')
-rw-r--r--app-vim/gitgutter/Manifest6
-rw-r--r--app-vim/gitgutter/gitgutter-20171101.ebuild28
-rw-r--r--app-vim/gitgutter/gitgutter-20180316.ebuild30
-rw-r--r--app-vim/gitgutter/gitgutter-99999999.ebuild30
-rw-r--r--app-vim/gitgutter/metadata.xml11
5 files changed, 105 insertions, 0 deletions
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
new file mode 100644
index 000000000000..02d1fc21f979
--- /dev/null
+++ b/app-vim/gitgutter/Manifest
@@ -0,0 +1,6 @@
+DIST gitgutter-20171101.tar.gz 43534 BLAKE2B cb0b935c1b2d16a50bbecc73f4f8c657a9087bef56bef36af8ff52a7ff09d39293296eaf49507015eaeac7f4faba2a26a09a49296c28237029110068cb9f6048 SHA512 24d8ad740931df17c2c67e2a2a13e3bba7c1205ba5543f5c11353e639876f4a54e69170dc0a946660ee2e3a23a110c90f4195fa9a1ddfff19163f00d88528219
+DIST gitgutter-20180316.tar.gz 46344 BLAKE2B f981753a0f8d066b7cb5c16c49cfdd1a1aac1c6623b4645b8b1abd5719470ac181e09c8b736f8b8a14e6098b60cb8f97b114dc5c2a587b6d1875fcf27b4b12cf SHA512 15873b2cccc49f8aec9de312efedc615d6fa822b45ca8ce53cc6cc878fcaf3a6ab3f02eb5d082ff329528cce1b48358846b0aba3f9d3bc8aadd29aa57d3b1a30
+EBUILD gitgutter-20171101.ebuild 752 BLAKE2B 02fecaa88d65823737070954f3a392036694794537c1953ea218d16952a659ad5813e6e67e348c9d56e70b392e10f954dd2c31ad95fb95833e7901cc7b1d3eb1 SHA512 8ce0c16f4f4942f8e0b33790601d42b2652d8310a496bb8d2f61713c612d210a93ac9be1aa9ed88bc99da088feafc9da9967285528d55701437465bcbb06ebfd
+EBUILD gitgutter-20180316.ebuild 791 BLAKE2B 1765bd9bdeb6234d90d831181bdf2ad0ef975edcfa959e7ea309c5522bdb6779163d1e5850a6715bcc8471db15c922125e80ec248d0ad822986657984475d4c8 SHA512 5b7fab9be3eabfe64a67535937883939ea3d1ba62184f55f25f18384ddf1d24416b22d1f88d6025d0b98249536984c6f8b6d0e9b7f0c467a64c14f34dfafde11
+EBUILD gitgutter-99999999.ebuild 791 BLAKE2B 1765bd9bdeb6234d90d831181bdf2ad0ef975edcfa959e7ea309c5522bdb6779163d1e5850a6715bcc8471db15c922125e80ec248d0ad822986657984475d4c8 SHA512 5b7fab9be3eabfe64a67535937883939ea3d1ba62184f55f25f18384ddf1d24416b22d1f88d6025d0b98249536984c6f8b6d0e9b7f0c467a64c14f34dfafde11
+MISC metadata.xml 346 BLAKE2B 89acd12a36beb7b027e42b7f094bba4e229e345ad6f0024bbd3e550784459975aff10e88f5de53de3f2150000b7349ee97348723110a43130b213404292b562a SHA512 4ada20b8f4f308445854b0e0ab229271a603e38370675691790dce0303ca4c2a7f00b247363b0f13bcebe78397fd3ebbbd157403260664171b548b8964da7a0a
diff --git a/app-vim/gitgutter/gitgutter-20171101.ebuild b/app-vim/gitgutter/gitgutter-20171101.ebuild
new file mode 100644
index 000000000000..2dada9f85e8b
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20171101.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="1e60667322b7cd1bfcba98762fbba746a888d21a"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+ rm LICENCE README* screenshot.png || die
+ rm -rf test || die
+}
diff --git a/app-vim/gitgutter/gitgutter-20180316.ebuild b/app-vim/gitgutter/gitgutter-20180316.ebuild
new file mode 100644
index 000000000000..002f6583087d
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20180316.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="37bdd03d176c5e182c7e8dbdc79c3f71d2a04898"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm LICENCE README* screenshot.png unplace.vim || die
+ rm -r test || die
+}
diff --git a/app-vim/gitgutter/gitgutter-99999999.ebuild b/app-vim/gitgutter/gitgutter-99999999.ebuild
new file mode 100644
index 000000000000..002f6583087d
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-99999999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="37bdd03d176c5e182c7e8dbdc79c3f71d2a04898"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm LICENCE README* screenshot.png unplace.vim || die
+ rm -r test || die
+}
diff --git a/app-vim/gitgutter/metadata.xml b/app-vim/gitgutter/metadata.xml
new file mode 100644
index 000000000000..8a1caee90de1
--- /dev/null
+++ b/app-vim/gitgutter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">airblade/vim-gitgutter</remote-id>
+ </upstream>
+</pkgmetadata>