summaryrefslogtreecommitdiff
path: root/app-vim/gitlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gitlog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gitlog')
-rw-r--r--app-vim/gitlog/Manifest6
-rw-r--r--app-vim/gitlog/gitlog-5.1.0.ebuild15
-rw-r--r--app-vim/gitlog/gitlog-6.0.0.ebuild21
-rw-r--r--app-vim/gitlog/gitlog-9999.ebuild21
-rw-r--r--app-vim/gitlog/metadata.xml11
5 files changed, 74 insertions, 0 deletions
diff --git a/app-vim/gitlog/Manifest b/app-vim/gitlog/Manifest
new file mode 100644
index 000000000000..7f8672b3352c
--- /dev/null
+++ b/app-vim/gitlog/Manifest
@@ -0,0 +1,6 @@
+DIST gitlog-5.1.0.tar.gz 29684 BLAKE2B 80d48890f25015c448a8acfd9ef9fb4da8e39ec61de0741d8fd9e33858a0696336b599b81ff379e0674a084d1bc80a6562721d963b4a5e60b611ff1fd741e867 SHA512 1c2bd363ce5341fcdaa80955af350084903da7e7cac1e20583d05f8812ef11e562137e2ef3bd198f787a6cc1e322f7d942135341c27186a7c987cd9d631a0eeb
+DIST gitlog-6.0.0.tar.gz 33956 BLAKE2B 5a7472db7cbf03396e3ed4e7eea417e44e538946d9432b4d94c3114b59bfeb961c6e0df4137c116f152b57986b7cbaa1aeacd59df33d709f2794f5d2607693c4 SHA512 17016057df69b22e72548d00bd8c253ace864f0551890f64e6b9a91c1411b1e0a479d6c04028583edf9f9c366418b50b758f60d197fe0a62a75c7799b68a4069
+EBUILD gitlog-5.1.0.ebuild 500 BLAKE2B 6234508aeea1aab566499ba99ce680606094205f1af6a3f0f9cea5be2c4c104ae7a5cc9c2da5b5529e5ac4b4af94ceb95776f5d7ded25aefccb920135cab0db4 SHA512 da8ed526bc9cef86e213a5b2786298ad5f24743ea50a2ccd22575cc90c35694836329203d5090480fb677dbfb10fc365fc7994d897204673560629f3628340aa
+EBUILD gitlog-6.0.0.ebuild 621 BLAKE2B 9f0c0cbe917d08f9e3a75e2ca9921007e41ca3eec8a111d7497ac0e411c858a209bcf0420b7e8e03d145419cc7d22bb1960df1ddde43a439079ef2e197acb111 SHA512 144f2c24bed882dfecd15538eb467e10ae29f29c04380b237725b808a19fe31a5fe4596a9f00a2e6e1a477921c52bcc18752f86b27f76afd7489e2994ec35fde
+EBUILD gitlog-9999.ebuild 621 BLAKE2B 9f0c0cbe917d08f9e3a75e2ca9921007e41ca3eec8a111d7497ac0e411c858a209bcf0420b7e8e03d145419cc7d22bb1960df1ddde43a439079ef2e197acb111 SHA512 144f2c24bed882dfecd15538eb467e10ae29f29c04380b237725b808a19fe31a5fe4596a9f00a2e6e1a477921c52bcc18752f86b27f76afd7489e2994ec35fde
+MISC metadata.xml 342 BLAKE2B c19182db6fcedd6a9b1117db5936015b4e0247e302b3dbf6e39ac1bdab719d9a5ab22706264004c5dfa75712ca9e9223187b10e90663139cf298ea84fcc55771 SHA512 419f19aff509708c460c7848a5e90c03a19c47c986ae6d5d07be0abb3a387a8045f89b98139d2ac0ac5abb16b9b8cd315fe3001a8808a2c1e4ee497449e23a60
diff --git a/app-vim/gitlog/gitlog-5.1.0.ebuild b/app-vim/gitlog/gitlog-5.1.0.ebuild
new file mode 100644
index 000000000000..55e58752e730
--- /dev/null
+++ b/app-vim/gitlog/gitlog-5.1.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: git log and diff plugin for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4294 https://github.com/PAntoine/vimgitlog/"
+SRC_URI="https://github.com/PAntoine/vimgitlog/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Artistic"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim${PN}-version_${PV}
diff --git a/app-vim/gitlog/gitlog-6.0.0.ebuild b/app-vim/gitlog/gitlog-6.0.0.ebuild
new file mode 100644
index 000000000000..658a3cb149c8
--- /dev/null
+++ b/app-vim/gitlog/gitlog-6.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/PAntoine/vimgitlog.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/PAntoine/vimgitlog/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/vim${PN}-version_${PV}
+fi
+
+DESCRIPTION="vim plugin: git log and diff plugin for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4294 https://github.com/PAntoine/vimgitlog/"
+LICENSE="Artistic"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
diff --git a/app-vim/gitlog/gitlog-9999.ebuild b/app-vim/gitlog/gitlog-9999.ebuild
new file mode 100644
index 000000000000..658a3cb149c8
--- /dev/null
+++ b/app-vim/gitlog/gitlog-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/PAntoine/vimgitlog.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/PAntoine/vimgitlog/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/vim${PN}-version_${PV}
+fi
+
+DESCRIPTION="vim plugin: git log and diff plugin for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4294 https://github.com/PAntoine/vimgitlog/"
+LICENSE="Artistic"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
diff --git a/app-vim/gitlog/metadata.xml b/app-vim/gitlog/metadata.xml
new file mode 100644
index 000000000000..94f21fcb2826
--- /dev/null
+++ b/app-vim/gitlog/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PAntoine/vimgitlog</remote-id>
+ </upstream>
+</pkgmetadata>