summaryrefslogtreecommitdiff
path: root/app-vim/gitv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gitv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gitv')
-rw-r--r--app-vim/gitv/Manifest4
-rw-r--r--app-vim/gitv/gitv-1.3.1.ebuild30
-rw-r--r--app-vim/gitv/gitv-9999.ebuild28
-rw-r--r--app-vim/gitv/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/app-vim/gitv/Manifest b/app-vim/gitv/Manifest
new file mode 100644
index 000000000000..703ef2073064
--- /dev/null
+++ b/app-vim/gitv/Manifest
@@ -0,0 +1,4 @@
+DIST gitv-1.3.1.tar.gz 553719 BLAKE2B 0d775f3bb05b3a49b69c5717f13a0f923fc5e0b5366c217042ac75e13c01080828ae4cd3e759e7dca44556c2b07aafa42cf8661a3ad0f52152c5cb8f4db294ed SHA512 e6a6773dcac18fdc36c891bd592d4dcb2eb20af6253df5886582fd223e040fb8296dc606d4fb25abd7a14f9dc1a712fe0e354821e234c8f54b1b5914af55dcbc
+EBUILD gitv-1.3.1.ebuild 684 BLAKE2B 2bc4aa2ca505cdbdc6ffae142b2905357e7054d0ce647bc7d5475f123c7756337e8460c38fb3d44fa6e43a13104bf20944ba8258b1c0bb9f76988315378c88fd SHA512 574878dc0b2f68da9bd39ad5467b343420e91ccd4fca3f5c69a7b75c837669a074dbfd54ed91cd7cfa7159a3301afad86091503c822e1808a6a34708ea62a778
+EBUILD gitv-9999.ebuild 683 BLAKE2B e2ceb93cb9bbd70a5764b7f93342e878caa463f639cb7ebf907ec230d1107977537df3298ec0d25d826330aa95aa4ebff6d3a5026fe49632b3d6d5eb74c0d651 SHA512 d42619dd5673761810cc3c5ceb434c9eaeb8bf5f39e5ea4e5909387a8cd79699320217a02edc14230a5b425683ece201fefcbdfa080842da87aca415ac842dd5
+MISC metadata.xml 339 BLAKE2B 7fcb97cc60c38b475e6ba392f55db1643e547903aa5f58ab5f81573681da85cba73e18de25dc3896321a971e99b44677322db3dda99afe1200ced4bfa49dcdf6 SHA512 ca3cb18c58b214701105d230d86f6499c1df741d0631483991465daa0680e3c3a8c2adb9440d828b98cf73fb598bcf33b4eb31ade16fe7faf31210663742344e
diff --git a/app-vim/gitv/gitv-1.3.1.ebuild b/app-vim/gitv/gitv-1.3.1.ebuild
new file mode 100644
index 000000000000..0c83e952b99e
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="
+ dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}
diff --git a/app-vim/gitv/gitv-9999.ebuild b/app-vim/gitv/gitv-9999.ebuild
new file mode 100644
index 000000000000..665594feb07b
--- /dev/null
+++ b/app-vim/gitv/gitv-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}
diff --git a/app-vim/gitv/metadata.xml b/app-vim/gitv/metadata.xml
new file mode 100644
index 000000000000..2bc2f53e2dc1
--- /dev/null
+++ b/app-vim/gitv/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gregsexton/gitv</remote-id>
+ </upstream>
+</pkgmetadata>