summaryrefslogtreecommitdiff
path: root/app-vim/gitv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/gitv
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/gitv')
-rw-r--r--app-vim/gitv/Manifest2
-rw-r--r--app-vim/gitv/gitv-1.3.1-r1.ebuild25
-rw-r--r--app-vim/gitv/gitv-9999.ebuild28
3 files changed, 26 insertions, 29 deletions
diff --git a/app-vim/gitv/Manifest b/app-vim/gitv/Manifest
index d032cc18830a..e3e35cf176b1 100644
--- a/app-vim/gitv/Manifest
+++ b/app-vim/gitv/Manifest
@@ -1,4 +1,4 @@
DIST gitv-1.3.1.tar.gz 553719 BLAKE2B 0d775f3bb05b3a49b69c5717f13a0f923fc5e0b5366c217042ac75e13c01080828ae4cd3e759e7dca44556c2b07aafa42cf8661a3ad0f52152c5cb8f4db294ed SHA512 e6a6773dcac18fdc36c891bd592d4dcb2eb20af6253df5886582fd223e040fb8296dc606d4fb25abd7a14f9dc1a712fe0e354821e234c8f54b1b5914af55dcbc
+EBUILD gitv-1.3.1-r1.ebuild 545 BLAKE2B 95b1ef7c9f7cbd408dac7ba02f4a63e8e97ed122fae5fe8df92ee48350059426211fa24fb015ec61c428f407271acf9b54af5b1983799a6017a84736258971ba SHA512 df7a52a6f75bb31f0fadc84384541033904c594295091d409456549e988d98093670508ae59b0c2fcaee9d14620b5331eac157b6bad4520d761186fe2e482639
EBUILD gitv-1.3.1.ebuild 654 BLAKE2B 5c9f903d09816b8fdfec4775736601edff78658165598f83e699d1b3b78b66ca9da714114e03a2c744b510ad563d9e9b1650c023f5122e39caf23cc66a9a3795 SHA512 0bbb35f1841d27c115248bb1d580c7b5db8f12f551db2956f3fb70b292aad1702548c034163ed23787e868b5581fad0ea1648eda22f48dd7aeab44bef331a3da
-EBUILD gitv-9999.ebuild 683 BLAKE2B e2ceb93cb9bbd70a5764b7f93342e878caa463f639cb7ebf907ec230d1107977537df3298ec0d25d826330aa95aa4ebff6d3a5026fe49632b3d6d5eb74c0d651 SHA512 d42619dd5673761810cc3c5ceb434c9eaeb8bf5f39e5ea4e5909387a8cd79699320217a02edc14230a5b425683ece201fefcbdfa080842da87aca415ac842dd5
MISC metadata.xml 340 BLAKE2B b1c28fd897ce61f3a49a17bf5ee05a4754a08fa9aae3fa99da56135450953e58126eeb237c60664e800ac434331881a88fb8f7d794715738a2c8ecf4ac53173a SHA512 be9ae917520a64b167b5a957de77ed0261448bccef97285c0b6cbba59e4c3969fd459e78d04a7aa41d632b5b1dfe9268a74008ed7443b0cd9db509dfc617afc1
diff --git a/app-vim/gitv/gitv-1.3.1-r1.ebuild b/app-vim/gitv/gitv-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..967936be8c8d
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86 ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="
+ dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags || die
+ rm -r img || die
+ default
+}
diff --git a/app-vim/gitv/gitv-9999.ebuild b/app-vim/gitv/gitv-9999.ebuild
deleted file mode 100644
index 665594feb07b..000000000000
--- a/app-vim/gitv/gitv-9999.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit vim-plugin
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
-else
- SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="vim plugin: gitk for vim"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
-LICENSE="vim"
-
-VIM_PLUGIN_HELPFILES="gitv"
-
-RDEPEND="dev-vcs/git
- app-vim/fugitive"
-
-src_prepare() {
- rm -f doc/tags addon-info.json roadmap.md || die
- rm -r img || die
- default
-}