summaryrefslogtreecommitdiff
path: root/app-vim/gnupg/gnupg-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/gnupg/gnupg-2.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/gnupg/gnupg-2.6.ebuild')
-rw-r--r--app-vim/gnupg/gnupg-2.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/gnupg/gnupg-2.6.ebuild b/app-vim/gnupg/gnupg-2.6.ebuild
new file mode 100644
index 000000000000..9729d06a6e81
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3645"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt || die
+}