summaryrefslogtreecommitdiff
path: root/app-vim/gnupg/gnupg-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gnupg/gnupg-2.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gnupg/gnupg-2.6.ebuild')
-rw-r--r--app-vim/gnupg/gnupg-2.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/gnupg/gnupg-2.6.ebuild b/app-vim/gnupg/gnupg-2.6.ebuild
new file mode 100644
index 000000000000..ef344bdcf3f9
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3645"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt || die
+}