summaryrefslogtreecommitdiff
path: root/app-vim/jedi/jedi-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-vim/jedi/jedi-0.10.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-vim/jedi/jedi-0.10.0.ebuild')
-rw-r--r--app-vim/jedi/jedi-0.10.0.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-vim/jedi/jedi-0.10.0.ebuild b/app-vim/jedi/jedi-0.10.0.ebuild
index ef127090588c..7b566e307035 100644
--- a/app-vim/jedi/jedi-0.10.0.ebuild
+++ b/app-vim/jedi/jedi-0.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit vim-plugin python-single-r1
@@ -19,7 +19,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_MULTI_USEDEP}]')
+ $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_USEDEP}]')
app-editors/vim[python]"
BDEPEND="${PYTHON_DEPS}
test? ( dev-python/pytest )"
@@ -32,10 +32,6 @@ RESTRICT="test"
# Makefile tries hard to call tests so let's silence this phase.
src_compile() { :; }
-src_install() {
- vim-plugin_src_install
-}
-
src_test() {
- pytest -vv || die
+ epytest
}