summaryrefslogtreecommitdiff
path: root/app-vim/jedi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-vim/jedi
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-vim/jedi')
-rw-r--r--app-vim/jedi/Manifest4
-rw-r--r--app-vim/jedi/jedi-0.10.0.ebuild37
-rw-r--r--app-vim/jedi/jedi-0.11.0.ebuild80
3 files changed, 82 insertions, 39 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
index 8ab068b6fd7b..8919068d55b8 100644
--- a/app-vim/jedi/Manifest
+++ b/app-vim/jedi/Manifest
@@ -1,3 +1,3 @@
-DIST jedi-0.10.0.tar.gz 36820 BLAKE2B a66f7c58564487d83867d61480d83364af0047cee713c41dbd5c67bff0b2ac33d066c2d0f4367c30059f46fb9f4916fc8d2eb9c64aa6a489e2c16a03f56b0b3c SHA512 65482505446b1001e92870ae64a147b38c0bb4d3151e464d325be741729506a191b284a491f4c3eb77dc46cb9bcd6b8e7bf8689ed95107e89a1f6a05c7fbc9ea
-EBUILD jedi-0.10.0.ebuild 833 BLAKE2B 2419296219ee6f21c4572edcd22bd11106478153297098a5e67b885797b28dc5d6f9cb36e33680a527852534c927307577d5c420b134cd2402913c913f408c4e SHA512 8857a9a90b5bb354147f66f8ea0dd5d31622a3436fad9dcb34b06d9b2b8e0a9fd5f43871fd666943bc83209f42fc3841a2d0b5c86ad76a1581551455d54f33bf
+DIST jedi-0.11.0.tar.gz 41606 BLAKE2B 146f60f43a3fc764c66e2ca94c2b4051be3e25b5a94ca3f6d82533b624433946013c7df38e61262e6ac40a00de9d3b9b0e647e794191b6deb8ed09124d2accc7 SHA512 a151fdf4d58adc36dbe9ede8e091ae00c8bd8237b66c512b4addfb6e7e436651848da2b3a0dbcbbef615bcc394e7e28a6e127e53f2205dc61f4d46a2ff0faa12
+EBUILD jedi-0.11.0.ebuild 2045 BLAKE2B bce0951b1aa604bb3fd12b0dcb7eef3ceef6026acdbf45f974299d2296a38fc9540eec2e3473fe9e0e74037ce5f1d77e51f141373889a1096c77cb9d04e4c9bf SHA512 c69e9a46287727325c8acfe92b4b3b6d77c2075382f69b35afbf1a3e5db3aebfdfc76dfc50bac6ecf51c49449c5b7b755734af928b531ed1617f61287c54ddcb
MISC metadata.xml 766 BLAKE2B d8f5fb163c91e7d140bc7921a21e7e939be641d69abf2c1048dc1bf6b766732dbd431b12f3de3f8ff5dbfefa2260375a811972a605f3c5aa863653a983cfcd59 SHA512 017ca02cb4643b7911bfb472cad02df81075fed0d139af7c818b78b1e972f5641e7def278427647ff294bc4cd5fa430ae2b49b5f92e5a7e783dbad54e1be355d
diff --git a/app-vim/jedi/jedi-0.10.0.ebuild b/app-vim/jedi/jedi-0.10.0.ebuild
deleted file mode 100644
index 7b566e307035..000000000000
--- a/app-vim/jedi/jedi-0.10.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit vim-plugin python-single-r1
-
-DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
-HOMEPAGE="https://github.com/davidhalter/jedi-vim"
-SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_USEDEP}]')
- app-editors/vim[python]"
-BDEPEND="${PYTHON_DEPS}
- test? ( dev-python/pytest )"
-
-S="${WORKDIR}/jedi-vim-${PV}"
-
-# Tests are broken.
-RESTRICT="test"
-
-# Makefile tries hard to call tests so let's silence this phase.
-src_compile() { :; }
-
-src_test() {
- epytest
-}
diff --git a/app-vim/jedi/jedi-0.11.0.ebuild b/app-vim/jedi/jedi-0.11.0.ebuild
new file mode 100644
index 000000000000..3afb7b0cf9b7
--- /dev/null
+++ b/app-vim/jedi/jedi-0.11.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit edo vim-plugin python-single-r1
+
+MY_PN="${PN}-vim"
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/jedi-0.18[${PYTHON_USEDEP}]')
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-vim/vspec
+ )
+"
+
+DOCS=( AUTHORS.txt CONTRIBUTING.md README.rst )
+
+src_prepare() {
+ vim-plugin_src_prepare
+
+ rm doc/logotype-a.svg || die
+ rmdir pythonx/{jedi,parso} || die
+
+ # Disable failing tests
+ sed -i test/vspec/signatures.vim \
+ -e "/it 'highlights correct argument'/a SKIP 'fail'" || die
+}
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_test() {
+ local bindir="${S}"/venv/bin
+ local sitedir="${S}"/venv/lib/${EPYTHON}/site-packages
+
+ mkdir -p "${bindir}" || die
+ mkdir -p "${sitedir}" || die
+ ln -s "${PYTHON}" "${bindir}/${EPYTHON}" || die
+ ln -s "${EPYTHON}" "${bindir}/python3" || die
+ ln -s "${EPYTHON}" "${bindir}/python" || die
+ cat > "${bindir}"/pyvenv.cfg <<-EOF || die
+ include-system-site-packages = false
+ EOF
+
+ ln -s "$(python_get_sitedir)"/parso "${sitedir}"/parso || die
+ cp -r "$(python_get_sitedir)"/parso-*.dist-info "${sitedir}" || die
+
+ ln -s "$(python_get_sitedir)"/jedi "${sitedir}"/jedi || die
+ cp -r "$(python_get_sitedir)"/jedi-*.dist-info "${sitedir}" || die
+
+ export PATH="${bindir}:${PATH}"
+ unset PYTHONPATH
+
+ edo prove-vspec -d "${S}" test/vspec
+}
+
+src_install() {
+ vim-plugin_src_install pythonx
+ python_optimize "${ED}"/usr/share/vim/vimfiles/pythonx
+}