summaryrefslogtreecommitdiff
path: root/app-vim/jedi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/jedi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/jedi')
-rw-r--r--app-vim/jedi/Manifest3
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015.ebuild33
-rw-r--r--app-vim/jedi/metadata.xml23
3 files changed, 59 insertions, 0 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
new file mode 100644
index 000000000000..3d5a3442c714
--- /dev/null
+++ b/app-vim/jedi/Manifest
@@ -0,0 +1,3 @@
+DIST jedi-0.8_p20171015.zip 43567 BLAKE2B 6065e2df567159054d99ec502ddb8ec8103e0892c9f78f6bbc2e72cad6cb3fe37d86882a72135f238fd47a747e03275aa82edee9d954459194940e8a69e1a775 SHA512 d69fa77ada22b0c75b7ec4ad1765035454312707ffb0f8a0bb0de4928e5fd21b08e39ab28b3f0ff9b37c8eb5389bc44c507fa2a08c0322510a57a91d7de028e6
+EBUILD jedi-0.8_p20171015.ebuild 824 BLAKE2B 4f953be2d3ce9601f944e849ad9fd0800304fd32cc5154bbffc4f2198cdfce55a1c6e3cbbe332e32999213a0d63a2e7a89878dfadd531955ea728fefc0111a71 SHA512 056d95e45463e930982698c031510c0b36d6276fd6870a617db179d3e8630a4793d1d3dc773adc20bc36e0ce7bcb34a06e99eb0cbb41239f630c22a91cffa99f
+MISC metadata.xml 740 BLAKE2B 82dbee0d839faa814f29236625da3bed8eaf6abf8e286c15800ae43758a017394e0b714896b721104213546554f56597a68556dec22038a730423df9a215963b SHA512 145652296b05261952034b26cf36a6fdabee22cdccf4b85914c383e1fde270ca66fcc0b5cae43294907b0730005eb3ce87feb39b716f89740277a9a133229142
diff --git a/app-vim/jedi/jedi-0.8_p20171015.ebuild b/app-vim/jedi/jedi-0.8_p20171015.ebuild
new file mode 100644
index 000000000000..f72dd11f5839
--- /dev/null
+++ b/app-vim/jedi/jedi-0.8_p20171015.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit vim-plugin python-r1 python-utils-r1
+
+# Commit Date: Sun Oct 15 20:51:54 2017 +0200
+COMMIT="77924398bd594e238766153cec97ace62650f082"
+
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]"
+DEPEND="app-editors/vim[python]"
+
+S="${WORKDIR}/jedi-vim-${COMMIT}"
+
+# Tests are broken.
+RESTRICT="test"
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+}
diff --git a/app-vim/jedi/metadata.xml b/app-vim/jedi/metadata.xml
new file mode 100644
index 000000000000..e29e8e7eb84b
--- /dev/null
+++ b/app-vim/jedi/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jedi-vim is a VIM binding to the autocompletion library Jedi.
+ Apart from that, jedi-vim provides a number of keybindings.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">davidhalter/jedi-vim</remote-id>
+ </upstream>
+</pkgmetadata>