summaryrefslogtreecommitdiff
path: root/app-vim/merginal/merginal-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /app-vim/merginal/merginal-2.1.0.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'app-vim/merginal/merginal-2.1.0.ebuild')
-rw-r--r--app-vim/merginal/merginal-2.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/merginal/merginal-2.1.0.ebuild b/app-vim/merginal/merginal-2.1.0.ebuild
new file mode 100644
index 000000000000..642e1deb87ae
--- /dev/null
+++ b/app-vim/merginal/merginal-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/idanarye/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+LICENSE="vim"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}