summaryrefslogtreecommitdiff
path: root/app-vim/merginal/merginal-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/merginal/merginal-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/merginal/merginal-9999.ebuild')
-rw-r--r--app-vim/merginal/merginal-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/merginal/merginal-9999.ebuild b/app-vim/merginal/merginal-9999.ebuild
new file mode 100644
index 000000000000..642e1deb87ae
--- /dev/null
+++ b/app-vim/merginal/merginal-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/idanarye/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+LICENSE="vim"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}