summaryrefslogtreecommitdiff
path: root/app-vim/pyclewn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/pyclewn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/pyclewn')
-rw-r--r--app-vim/pyclewn/Manifest5
-rw-r--r--app-vim/pyclewn/metadata.xml16
-rw-r--r--app-vim/pyclewn/pyclewn-2.0.1.ebuild46
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r1.ebuild51
4 files changed, 118 insertions, 0 deletions
diff --git a/app-vim/pyclewn/Manifest b/app-vim/pyclewn/Manifest
new file mode 100644
index 000000000000..ceb4ff37d5c7
--- /dev/null
+++ b/app-vim/pyclewn/Manifest
@@ -0,0 +1,5 @@
+DIST pyclewn-2.0.1.tar.gz 124914 BLAKE2B e1dc12174d2ac640476a36714a8ef221f64db4b19c9509a179bc0cf573200de0f1f888bcc3bb69f433064e2de2d881845099f609468e12ed72e5c547623d44e5 SHA512 996acbedbb7922109925f188efba4c71e83f1823c029f92dc00bb21449f024232ef55df0c74a9fd4bfa7229523ed9ad4301aa9dbb8a3c20424082fc6939f63db
+DIST pyclewn-2.1.tar.gz 129697 BLAKE2B 0dfef92cb36ea9fa89c7f0d85ed45e21c634732fc2d3d888dd792de22529bea86719f8ac8ed870dd5ab00efbfdb08011013a36880781abf9e0c64a62b2aa301a SHA512 346b98a9e37957a5bf97b8901247f56fa8e38bddac38727867773cf4e78e555d6a85848c4c400d1faf1159ba61122cfd4931c95a67e3b2abdfaae7996beb4f1b
+EBUILD pyclewn-2.0.1.ebuild 1057 BLAKE2B 1412bfe77432b791290c9a4d707fcc3c41c17384e4f35fb730d920a3c7dec35f4a7c674e2a107ec952413f88d1eb837c262b9fd9dc35c4c3b104bc29a52fcf83 SHA512 729fe02cffcd975dc3735c5c003bfb8db1d5b1044ff395afb776de09efc0c2dac828cb74600acec811a5e311fa27f096641c03cea19f6bd2d92c2e107f1c271e
+EBUILD pyclewn-2.1-r1.ebuild 1120 BLAKE2B 5bb45ffde48cb5571ef0c529b3017bfca6205cf6b0a17a0f111229525b1b76efcb0f741a3ea9f9a1dee5c6c1632521688f33844f4f0f62b7e1b015fbbffafd2c SHA512 d9671d291b255388bb8f6d2de19f6e7177cb6a3f322d72fa640a747c6bfde9e32f8e3d780632902872c5753b6c1f920be5a11fe11196fb647d21888e783a851f
+MISC metadata.xml 499 BLAKE2B 4955bd7a080dc2ae909143477040d191cb48ab4badfd47b6b7c11fd4686139bbbe77475f005e10c3b2bba50d0615b94600a55cda57a7d02ecaaffe1e504219dd SHA512 30b127677f0d5a9afce208e5cbb00c9b98f6d7e771ef273155f9acad764da789e71249289104e8006420cf5ff62075bb7572527150f9b339e0e51cb219c76a81
diff --git a/app-vim/pyclewn/metadata.xml b/app-vim/pyclewn/metadata.xml
new file mode 100644
index 000000000000..a93aab33c5ba
--- /dev/null
+++ b/app-vim/pyclewn/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyclewn</remote-id>
+ <remote-id type="sourceforge">pyclewn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/pyclewn/pyclewn-2.0.1.ebuild b/app-vim/pyclewn/pyclewn-2.0.1.ebuild
new file mode 100644
index 000000000000..cd2bed6c6c96
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3[${PYTHON_USEDEP}]
+ >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
+)"
+DEPEND="${CDEPEND}
+ app-arch/vimball
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
new file mode 100644
index 000000000000..403ecdc6fe16
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3
+ >=app-editors/gvim-7.3[netbeans]
+)"
+
+DEPEND="
+ ${CDEPEND}
+ app-arch/vimball"
+
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/pdb-clone[${PYTHON_USEDEP}]' python{2_7,3_5})
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}