summaryrefslogtreecommitdiff
path: root/app-vim/pydiction
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/pydiction
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/pydiction')
-rw-r--r--app-vim/pydiction/Manifest5
-rw-r--r--app-vim/pydiction/metadata.xml12
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r1.ebuild30
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild38
-rw-r--r--app-vim/pydiction/pydiction-1.2.3.ebuild25
5 files changed, 110 insertions, 0 deletions
diff --git a/app-vim/pydiction/Manifest b/app-vim/pydiction/Manifest
new file mode 100644
index 000000000000..e0c7ac91ad00
--- /dev/null
+++ b/app-vim/pydiction/Manifest
@@ -0,0 +1,5 @@
+DIST pydiction-1.2.3.zip 475441 BLAKE2B 709d4de30d21ff0ba27b5b0c11276731bdef03d754c1799857ceba7edbea4fc0640714cda4103ed58878b02cc00feed5d6b08df2647139fa84910cf92db51dea SHA512 91da1d8a9be89095072724d77bdcaa342fbd5479f5027d7ed7bb2d4a382c7385b2b7fae91c1cd94605232b34a96370a86096e3c32db0d106cbcda2a82f409922
+EBUILD pydiction-1.2.3-r1.ebuild 701 BLAKE2B 9b75ffd2cacdb6aca0ed5d9086df249745d749cac7182625511c066865e0c3e0bb0f3a791797c213dbe1d01e8de4afbea6c6e1343b5a1124d4cf41fcc78d0ad0 SHA512 60c6cab108c87042e3b01e3a2329429cba70f883d97bf7217e7e5b07c7553745c07bb74d7e250b736af21a99e831b70b0610a8cda6fdff0f100f85d6b13e2856
+EBUILD pydiction-1.2.3-r2.ebuild 948 BLAKE2B 51e04a857b036fa362a5cc42da933f55628d561ab73e98c543ac2af6e3046549adb67801814d5e915a6fbb201ad3664beb46aff72bcd9a05cbdb5787372d02d1 SHA512 3b0a0cc5082d460987d4b16a127980528ff37eee2842a3b31c1d6a915b1ea0a437a3404c88184c4021083679d10bebe88e6137b105af7582bd96e4aef64b394a
+EBUILD pydiction-1.2.3.ebuild 598 BLAKE2B 240a494c6547fafa7d1f98a241a9e3072e4c758b1dcb7bc9f3bd6996d33ba94df765fd5ff8993729d49570e96416bc59b60c15644971625fec7e7786e79b2b56 SHA512 11d845c3d011daab5bcc676581a347974731166f689e7c2e41f6a0fe680f865079c2275d14632c3cbd901b187bb1ee3a829a07ceec77f32332f66ec74ca6d5e6
+MISC metadata.xml 361 BLAKE2B 4cd18ca933890f32a2aca909c66c48ea1539fc4d4d558657e5fb76c66a26be7c9b24882b7688b54407e044ba1e4d641e659da10065360ddba91dad4aa391da5e SHA512 f205ce2b8f61bcc7d966345b9928efccdc2adb4ce6a36166c774134bd8959a3757a3a9a556aaa2d6c6f7b71b945be84e41903a58e66f844c4258326a66b2b667
diff --git a/app-vim/pydiction/metadata.xml b/app-vim/pydiction/metadata.xml
new file mode 100644
index 000000000000..8fafbfec1948
--- /dev/null
+++ b/app-vim/pydiction/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/pydiction/pydiction-1.2.3-r1.ebuild b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..0e9e20b9d9ba
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-r1
+
+DESCRIPTION="vim plugin: tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..a0972c26972c
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-r1
+
+DESCRIPTION="vim plugin: tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ # Rename pydiction script.
+ mv "${PN}.py" "${PN}" || die
+
+ # We're going to remove those files in a second
+ # otherwise they're installed by Portage.
+ local pyfiles=( complete-dict "${PN}" )
+ insinto "/usr/share/${P}"
+ doins complete-dict
+
+ # pydiction is treated a singular script that lives on its own.
+ python_foreach_impl python_doscript "${PN}"
+ rm -v "${pyfiles[@]}" || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/pydiction/pydiction-1.2.3.ebuild b/app-vim/pydiction/pydiction-1.2.3.ebuild
new file mode 100644
index 000000000000..c4fae8228716
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="vim"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/python:*"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}