summaryrefslogtreecommitdiff
path: root/app-vim/pydoc/pydoc-2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
commit290844d409ace33d948956aec3c542ea6f4a7b13 (patch)
treea1849e2730c9848c11d12aa322070e4e87edb729 /app-vim/pydoc/pydoc-2.0-r2.ebuild
parent31459e63971ac3b08706bba949851d93c45043c3 (diff)
gentoo auto-resync : 01:10:2022 - 01:09:37
Diffstat (limited to 'app-vim/pydoc/pydoc-2.0-r2.ebuild')
-rw-r--r--app-vim/pydoc/pydoc-2.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/pydoc/pydoc-2.0-r2.ebuild b/app-vim/pydoc/pydoc-2.0-r2.ebuild
new file mode 100644
index 000000000000..a33f308db8de
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=910
+ https://github.com/fs111/pydoc.vim"
+SRC_URI="
+ https://github.com/fs111/${PN}.vim/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}.vim-${PV}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"