summaryrefslogtreecommitdiff
path: root/app-vim/tagbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/tagbar
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/tagbar')
-rw-r--r--app-vim/tagbar/Manifest5
-rw-r--r--app-vim/tagbar/metadata.xml11
-rw-r--r--app-vim/tagbar/tagbar-2.6.1.ebuild17
-rw-r--r--app-vim/tagbar/tagbar-2.7.ebuild22
4 files changed, 55 insertions, 0 deletions
diff --git a/app-vim/tagbar/Manifest b/app-vim/tagbar/Manifest
new file mode 100644
index 000000000000..bcb5ecc3b2ac
--- /dev/null
+++ b/app-vim/tagbar/Manifest
@@ -0,0 +1,5 @@
+DIST tagbar-2.6.1.tar.gz 51639 BLAKE2B 623f56dfb1ce7abde3281d9e1564e300f30cbfa9242772532025dd3d85640118b85ad3f68d20d6806ff3d994ba753722e096098231f750195569afc47635487e SHA512 eb0f29dc2f08d943e1ac0c0fe97ed72a49b85e22d105815a5557e205532be379d3ce8429c5303b917c005b465a7385161ff2edc96efc0fc312178155c67a7c22
+DIST tagbar-2.7.tar.gz 59027 BLAKE2B 6966ee9c412b0e7c9dd562f479ab4ae3fb4574034a32e33257ce95850f2861e333682d01d605f1c39dd6675a506e1792fed8a470b08152d14046bea215292698 SHA512 d964d3055f1679aad86b0756cc444a4857eb29ca22f2bd3567ad6c8d073e75d0c8823109038415f5bd1d269bbf8e36da6f34d70fedee54c10f90535ef79ff3c8
+EBUILD tagbar-2.6.1.ebuild 500 BLAKE2B 84300000ac7c06dcc5b1c2576022bd6918f475977de6f7eb1becea74fcb0cf3ddfa22bdef017572446fc4d3e2453683df706fc3ad5552ca432a0fbcef7680b65 SHA512 ebd88ae5174fa3b8438f3e77d088c0606d1148c4ed494395ff97908525a1d81f2d87d2001a9fda08c2b15ab0c9624ef6c437dd61c5358cf650962059ac50527e
+EBUILD tagbar-2.7.ebuild 549 BLAKE2B 2d0ccd8b0f6bc4e0e6d4407c20f7f608a88345e7e4f9a40fe544a9805d38d825ae8ba0e987a4e3e95b8e89b9de71a7237cdc45665fbc34aee67a073d10d0887e SHA512 53abc5047d1ad81ce73a8761d65ca969c3f17c4e37333a417a4568915a8edd38f3909fe400f3e5fe8ce2aea51bf55a4d0572e4b363ec9403954fba2eb41da47d
+MISC metadata.xml 341 BLAKE2B 4a1c8210c02cd207a9772371a9f4a02308352360991a6d8734579a3fe79a40716b6fd310b16ba6359e869843cf8b3e80be9dbb62636cfb1eaa924d3217a31e65 SHA512 adfd265c7224b9d6f4013721066f15e26baf908c0c89b0357f0a6d92797ee08eecfaa6b3c28d5117b88e258f6a0eb2fbd2704c701a11da6dd6095511a298eefe
diff --git a/app-vim/tagbar/metadata.xml b/app-vim/tagbar/metadata.xml
new file mode 100644
index 000000000000..f571998c87da
--- /dev/null
+++ b/app-vim/tagbar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">majutsushi/tagbar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/tagbar/tagbar-2.6.1.ebuild b/app-vim/tagbar/tagbar-2.6.1.ebuild
new file mode 100644
index 000000000000..a1c2e7fb7e0a
--- /dev/null
+++ b/app-vim/tagbar/tagbar-2.6.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display tags of the current file ordered by scope"
+HOMEPAGE="https://majutsushi.github.com/tagbar/
+ https://www.vim.org/scripts/script.php?script_id=3465"
+SRC_URI="https://github.com/majutsushi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=dev-util/ctags-5.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
diff --git a/app-vim/tagbar/tagbar-2.7.ebuild b/app-vim/tagbar/tagbar-2.7.ebuild
new file mode 100644
index 000000000000..211696e57ae9
--- /dev/null
+++ b/app-vim/tagbar/tagbar-2.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display tags of the current file ordered by scope"
+HOMEPAGE="https://majutsushi.github.com/tagbar/
+ https://www.vim.org/scripts/script.php?script_id=3465"
+SRC_URI="https://github.com/majutsushi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-util/ctags-5.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm LICENSE || die
+ default
+}