summaryrefslogtreecommitdiff
path: root/app-vim/tagbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /app-vim/tagbar
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'app-vim/tagbar')
-rw-r--r--app-vim/tagbar/Manifest1
-rw-r--r--app-vim/tagbar/tagbar-2.7-r1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/tagbar/Manifest b/app-vim/tagbar/Manifest
index dddc4e26a59e..3cdc2144710f 100644
--- a/app-vim/tagbar/Manifest
+++ b/app-vim/tagbar/Manifest
@@ -1,3 +1,4 @@
DIST tagbar-2.7.tar.gz 59027 BLAKE2B 6966ee9c412b0e7c9dd562f479ab4ae3fb4574034a32e33257ce95850f2861e333682d01d605f1c39dd6675a506e1792fed8a470b08152d14046bea215292698 SHA512 d964d3055f1679aad86b0756cc444a4857eb29ca22f2bd3567ad6c8d073e75d0c8823109038415f5bd1d269bbf8e36da6f34d70fedee54c10f90535ef79ff3c8
+EBUILD tagbar-2.7-r1.ebuild 499 BLAKE2B a8663fbe5ef6949baad94a804c75ff21c52d8ed2c3b884c18f59b16459168b7ec4b822474fad4d25a62582a365ec4988f574bbfb7a2d48c5de47733085489934 SHA512 810fa8b1bcaa6c00ec5b2ed7a9bf2cb0ac02e5c6d2875a70b834f8133540233dca3bbefc3411e6b4d722ea7ba246f5931e924a3a076d12c3b65bde905c595c91
EBUILD tagbar-2.7.ebuild 494 BLAKE2B ff14e2a0e0d4d601aa9721047872c07e7fc1f0d199eb28b42fd864affa4c6c3bfc629ee3f5dc88aae1a1de97f6ed5e2a51774130ce770c91feaa34e288aef136 SHA512 c8f8e026e454ce461be52f78b7f6d679a70917a2307d10df2d3b6b0ba4d6a20bb29c2d270e7a8f0c7d33137f563116d3f458ab08ac545798663ef46732ab5370
MISC metadata.xml 367 BLAKE2B 9fcb480d6d328867939a1029268d179641e26f12e5d754a7ed14ffccc037814935c1fdd45d62223fab183a8720552c65d14570f640b13d50c808714d9af3f499 SHA512 5b86774b3c2fae261a0bec0fe7b4b3dff72f851e0c2ffddbacedd736a9854b8bc100bad3c32aa7ea847522e99e4261bc2c974ac625a56b9b4e1ac3a7e9be0fa6
diff --git a/app-vim/tagbar/tagbar-2.7-r1.ebuild b/app-vim/tagbar/tagbar-2.7-r1.ebuild
new file mode 100644
index 000000000000..d3ad7238cf7f
--- /dev/null
+++ b/app-vim/tagbar/tagbar-2.7-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display tags of the current file ordered by scope"
+HOMEPAGE="
+ https://github.com/preservim/tagbar
+ https://www.vim.org/scripts/script.php?script_id=3465
+"
+SRC_URI="https://github.com/preservim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-util/ctags-5.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"