summaryrefslogtreecommitdiff
path: root/app-vim/tlib/tlib-1.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-vim/tlib/tlib-1.27.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-vim/tlib/tlib-1.27.ebuild')
-rw-r--r--app-vim/tlib/tlib-1.27.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/tlib/tlib-1.27.ebuild b/app-vim/tlib/tlib-1.27.ebuild
new file mode 100644
index 000000000000..aac06503bc74
--- /dev/null
+++ b/app-vim/tlib/tlib-1.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN=${PN}_vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a library of utility functions"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1863 https://github.com/tomtom/tlib_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( README CHANGES.TXT )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-error-E1208-vim-8.2.3141.patch
+)
+
+src_prepare() {
+ default
+ rm -r test samples || die
+}