summaryrefslogtreecommitdiff
path: root/app-vim/vim-autoclose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim-autoclose
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim-autoclose')
-rw-r--r--app-vim/vim-autoclose/Manifest3
-rw-r--r--app-vim/vim-autoclose/metadata.xml15
-rw-r--r--app-vim/vim-autoclose/vim-autoclose-2.0.ebuild17
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/vim-autoclose/Manifest b/app-vim/vim-autoclose/Manifest
new file mode 100644
index 000000000000..958b77fa467c
--- /dev/null
+++ b/app-vim/vim-autoclose/Manifest
@@ -0,0 +1,3 @@
+DIST vim-autoclose-2.0.tar.gz 35779 BLAKE2B bf1536b3cdeecfc261ee30687d53ac2dd7632e21e877a67a99aa21e1d9e4389e3d1d3de764c76d94a8d97fa2bad1c7877276a5defa6b2ca137f1a8e866e902b0 SHA512 2604c2c16f25eb60bf660ba4f80d40d9aa51af38cc59a2727f0c705ba2abe5302a58dc60a71c791cc6aa002477587d1dadcc8a9269a93c5a9405a86251f4fcd9
+EBUILD vim-autoclose-2.0.ebuild 389 BLAKE2B d865dc00c7975075ed2d6ff4627d2e6fd7f86e55aeea70e6736995ad7729c481976361611cfc2008986f9578aeba4e6d60e2434a5e5e960b64fdfde551b833ca SHA512 ea690cb014599f55d7c658d76186a898ca3e7f787966bece9d2538dd94bf9a08a6ce62226ed10834013b4bb10e81eec5cddd18b33832da138aa018d63db1af17
+MISC metadata.xml 445 BLAKE2B bb09273cbcd52c149f21155f0b234ee70f2946038e509427f7ef6f3842af9825e41a569a8350ef93d671db7830d7c14269a21e399d640ee172edc02ba082daea SHA512 a78dd7130e0cba7566721294c9e3c7c90481f4eaff8d0d84ad3ad015c9afff79e0972335f9cb7bf9ac15e3f083853a6160c5654d6a0ab6dd2f20c047b4e7f8a5
diff --git a/app-vim/vim-autoclose/metadata.xml b/app-vim/vim-autoclose/metadata.xml
new file mode 100644
index 000000000000..0e5ce60b28e0
--- /dev/null
+++ b/app-vim/vim-autoclose/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Townk/vim-autoclose</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
new file mode 100644
index 000000000000..b831f463e574
--- /dev/null
+++ b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open-close pair of characters"
+HOMEPAGE="https://github.com/Townk/vim-autoclose"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}