summaryrefslogtreecommitdiff
path: root/app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild')
-rw-r--r--app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild b/app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild
new file mode 100644
index 000000000000..3073736b57a5
--- /dev/null
+++ b/app-vim/vim-nftables/vim-nftables-0_pre20200629-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="26f8a506c6f3e41f1e4a8d6aa94c9a79a666bbff"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/nfnty/vim-nftables"
+SRC_URI="https://github.com/nfnty/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/vim-nftables-0_pre2020062901-no-expandtab.patch"
+)
+
+src_prepare() {
+ default
+
+ # will install license file by default
+ rm LICENSE || die
+}