summaryrefslogtreecommitdiff
path: root/app-vim/vimagit/vimagit-1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-vim/vimagit/vimagit-1.7.3.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-vim/vimagit/vimagit-1.7.3.ebuild')
-rw-r--r--app-vim/vimagit/vimagit-1.7.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimagit/vimagit-1.7.3.ebuild b/app-vim/vimagit/vimagit-1.7.3.ebuild
new file mode 100644
index 000000000000..2fa87c6aceb4
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}