summaryrefslogtreecommitdiff
path: root/app-vim/vimbuddy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vimbuddy
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vimbuddy')
-rw-r--r--app-vim/vimbuddy/Manifest5
-rw-r--r--app-vim/vimbuddy/metadata.xml11
-rw-r--r--app-vim/vimbuddy/vimbuddy-0.9.2-r1.ebuild17
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/vimbuddy/Manifest b/app-vim/vimbuddy/Manifest
new file mode 100644
index 000000000000..d2099bf8bea1
--- /dev/null
+++ b/app-vim/vimbuddy/Manifest
@@ -0,0 +1,5 @@
+DIST vimbuddy-0.9.2.zip 1547 SHA256 53cb3ebbe6c0ce74e0a1edc668ff55f62a37e3594b7cb5377d181239e2cc7f72 SHA512 cf42e9c2898e4b5335341215019c732075da7821c25c2887e718d0ae428c390afc5c81c9724c738f74b81d125e9b995dc279411e3a23e048e704bb1e3648e680 WHIRLPOOL e2768e2d34ee391cdaf10e9a0b6c6d8e8ddc1ce8afedbf42d263922cd9aee43a7071354782742f80665ba3caf95504f746a6c7582996130ae43eb121133df041
+EBUILD vimbuddy-0.9.2-r1.ebuild 522 SHA256 cfb3a14057cf8ac907f0389aceebf9d0645a5f51bfe4275589fbbb2e2ef28bcd SHA512 b3644d55c727d4b54efd0f6f695c8b96bf6fdc0fe3ee460ac18b0f09d2ff37ffaf304c1596491fcaeeb36962bc37211068006624503e950ef618e451797171f9 WHIRLPOOL 1e3923a1e15f92efdbf0a2f38b0a7ae5503c22dfa2f50a752c37a549dc318268b3f438e04eef0337171947bedb065e3ca7d54075fa367ee5924227821380fef4
+MISC ChangeLog 2784 SHA256 38e3d61356f2b239fd0a993fccfadcaa7cf000bb7fe6a513558476a74692d4e3 SHA512 63cfdf49b06ca7204106054ba91ab88f38f2298e3c545f663acc0e60587e6ffe4cb10135732ee3e0c4be32698c8542cae6007fce9d5da00e8bebe02d72726a6c WHIRLPOOL 84102bf72f345325052e0d524764b3dfce9f4b7273461abf2e5b49a99011f3e7c4849ab9ebd8de4f4d01c10bbeec982028cbcf7ec3ddcff2303105052089fcaf
+MISC ChangeLog-2015 2763 SHA256 1688ea873152d335e7a4d44ce0c26741f2cf70a71bccf357f21f547a93e04098 SHA512 ae88315bebece9be1c9f2a34304dc32cb7228706e81f1b723d5872c9187650845968c19af9337dd25a4340c67731a47712e2a8951d56ba953458242fc70d47da WHIRLPOOL a77a884eaf89ff323a370f924b4eabd7055c6ff3a19eaff02ebb6ecd72d48ffd1c30aa4da6d673d4d8f8d7d56da1b2cba52116a75c96783f6f105365fb7f68d4
+MISC metadata.xml 338 SHA256 e88c75e1116443acc1bb36a08477b53a088700262f096b725078d03017261e34 SHA512 1a949dd9cc669a43a63ac53b3429325ab44873aee6ffa02c8e8f1abfd64d47c6645c1c4fd4a312cba81de1196abee5ceee5510e59b6637bc19cd34880ff32048 WHIRLPOOL a267b8e917aa708b5bd45012b9f9ac29c62e743d66296addb91e169f7c21d117b9284e0e2a3fb1507e06e91163d85b660a2bba8a370a7fdbbe56f732dc1886d5
diff --git a/app-vim/vimbuddy/metadata.xml b/app-vim/vimbuddy/metadata.xml
new file mode 100644
index 000000000000..0cf1ee0aac77
--- /dev/null
+++ b/app-vim/vimbuddy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/vimbuddy.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vimbuddy/vimbuddy-0.9.2-r1.ebuild b/app-vim/vimbuddy/vimbuddy-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..8cd913f07dd4
--- /dev/null
+++ b/app-vim/vimbuddy/vimbuddy-0.9.2-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: vimbuddy for the status line"
+HOMEPAGE="https://github.com/vim-scripts/vimbuddy.vim"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="public-domain"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${PN}.vim-${PV}"
+
+VIM_PLUGIN_HELPURI="http://www.vim.org/scripts/script.php?script_id=8"