summaryrefslogtreecommitdiff
path: root/app-vim/xquery-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/xquery-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/xquery-syntax')
-rw-r--r--app-vim/xquery-syntax/Manifest3
-rw-r--r--app-vim/xquery-syntax/metadata.xml8
-rw-r--r--app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild23
3 files changed, 34 insertions, 0 deletions
diff --git a/app-vim/xquery-syntax/Manifest b/app-vim/xquery-syntax/Manifest
new file mode 100644
index 000000000000..75f8027f3bb0
--- /dev/null
+++ b/app-vim/xquery-syntax/Manifest
@@ -0,0 +1,3 @@
+DIST xquery-syntax-0.1.tar.bz2 1552 BLAKE2B e33f5359d3059c7558516939e2ce14c906f12fd4b7c5d035cdbadc9485e1fc992e50a2c38685d27ffae40dc7b22375c6825ae414131846ff0c19d68484750ad0 SHA512 277503e2d7089702c58b2e04a48345e579b6cfdee5042da90e8401b914c1d515c811cbf71f6dedbeee4a21e7a4807bd0d694323ddb2bd6b9437edaaba5a0f2fd
+EBUILD xquery-syntax-0.1-r2.ebuild 584 BLAKE2B 0bf0662e91084d66fa5cc858a50dd2742a81ba095601391d86ed0a2af94bd9b82f0903ab27273ea05fa724cb0f5957a730786313bb35cd6b1b48be5cec051c43 SHA512 e159a1c317efe2e189cd3652f2c4ca255d5ea89b77924a2d8437a9b15e2474a4fb39f30db2bcf43f3eae8be13af9060998f9ef796c616d491b9321c7b19383ae
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/xquery-syntax/metadata.xml b/app-vim/xquery-syntax/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/xquery-syntax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
new file mode 100644
index 000000000000..4261c5cc64e3
--- /dev/null
+++ b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: XQuery syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=803"
+
+LICENSE="vim.org"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for XQuery files."
+
+src_prepare() {
+ default
+ # use hi def link. Bug #101788, bug #101804.
+ sed -i -e 's,^hi\(ghlight\)\? link,hi def link,' syntax/xquery.vim \
+ || die "sed failed"
+}