summaryrefslogtreecommitdiff
path: root/dev-ada/aunit/aunit-22.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ada/aunit/aunit-22.0.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ada/aunit/aunit-22.0.0.ebuild')
-rw-r--r--dev-ada/aunit/aunit-22.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ada/aunit/aunit-22.0.0.ebuild b/dev-ada/aunit/aunit-22.0.0.ebuild
new file mode 100644
index 000000000000..78a102da278f
--- /dev/null
+++ b/dev-ada/aunit/aunit-22.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_202{0..1} )
+inherit ada multiprocessing
+
+DESCRIPTION="Ada unit testing framework"
+HOMEPAGE="http://libre.adacore.com/tools/aunit/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
+
+src_compile() {
+ emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ einstalldocs
+ mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
+ rmdir "${D}"/usr/share/examples || die
+ rm -r "${D}"/usr/share/gpr/manifests || die
+}
+
+src_test() {
+ emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
+}