summaryrefslogtreecommitdiff
path: root/dev-ada/aunit/aunit-22.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /dev-ada/aunit/aunit-22.0.0.ebuild
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'dev-ada/aunit/aunit-22.0.0.ebuild')
-rw-r--r--dev-ada/aunit/aunit-22.0.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ada/aunit/aunit-22.0.0.ebuild b/dev-ada/aunit/aunit-22.0.0.ebuild
index 78a102da278f..f4f6f8098704 100644
--- a/dev-ada/aunit/aunit-22.0.0.ebuild
+++ b/dev-ada/aunit/aunit-22.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-ADA_COMPAT=( gnat_202{0..1} )
+ADA_COMPAT=( gnat_202{0..1} gcc_12_2_0 )
inherit ada multiprocessing
DESCRIPTION="Ada unit testing framework"
@@ -22,7 +22,10 @@ DEPEND="${RDEPEND}
REQUIRED_USE="${ADA_REQUIRED_USE}"
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2016-gentoo.patch
+ "${FILESDIR}"/${P}-redundant.patch
+)
src_compile() {
emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"